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WARNING: 

 

Read and follow ALL operating instructions and safety warnings set forth in the ServoCam™ User's 
Manual before operating this equipment.  DO NOT allow untrained personnel to operate, clean, 
inspect, maintain, service, or tamper with this equipment. 

 

Read and follow ALL operating instructions and safety warnings for the automatic screw machine to 
which the ServoCam™ system is attached before operating this equipment.  DO NOT allow untrained 
personnel to operate, clean, inspect, maintain, service, or tamper with this equipment. 

 

NEVER REMOVE OR DISABLE ANY SAFETY GUARDS OR FEATURES from the ServoCam® 
system or the automatic screw machine to which the ServoCam® system is attached. 

 

IN CASE OF EMERGENCY OR MACHINE MALFUNCTION, IMMEDIATELY PRESS THE LARGE 
RED TOOL STOP BUTTON ON THE FRONT OF THE SERVOCAM® CONTROLLER.  NOTE THAT 
DEPRESSING THE TOOL STOP BUTTON DOES NOT REMOVE POWER FROM THE AUTOMATIC 
SCREW MACHINE DRIVE MOTOR OR ACCESSORY MOTORS.  DO NOT RELEASE THE TOOL 
STOP BUTTON UNTIL ALL PERSONNEL ARE CLEAR OF THE AUTOMATIC SCREW MACHINE. 

 

THE SERVOCAM® SYSTEM MAY AT ANY TIME CAUSE THE TURRET SLIDE TO MOVE 
UNEXPECTEDLY, EVEN IF THE AUTOMATIC SCREW MACHINE CLUTCH IS DISENGAGED.  
ALWAYS DEPRESS THE LARGE RED TOOL STOP BUTTON ON THE FRONT OF THE 
CONTROLLER BEFORE PLACING YOUR HANDS OR FINGERS ANYWHERE NEAR THE 
TURRET SLIDE, TURRET, OR WORKPIECE. 

 

When the YELLOW light on the ServoCam® controller is illuminated, the turret slide is unlocated by 
the controller and WILL NOT STOP AUTOMATICALLY.  KEEP THE TURRET SLIDE OF THE 
AUTOMATIC SCREW MACHINE AWAY FROM THE ENDS OF ITS TRAVEL. 

 

ONLY PERMIT QUALIFIED PERSONNEL TO SERVICE OR ADJUST THE SERVOCAM® SYSTEM.  
EXERCISE CARE WHEN MAKING CHECKS, TESTS, AND ADJUSTMENTS THAT MUST BE 
MADE WITH POWER ON.  FAILURE TO OBSERVE THESE PRECAUTIONS CAN RESULT IN 
INJURY OR DEATH. 

©AMT Machine Systems, Ltd. 1998-2007.  All rights reserved.  No part of this manual may be reproduced or transmitted in any form or by any 

means, electronic or mechanical, including photocopying and recording, for any purpose without the express written permission of AMT Machine 

Systems, Ltd. 
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Chapter 1  Overview 
 

 

Introduction 
The base ServoCam® UltraSlide™ system is a bolt-on CNC replacement 

for the turret-slide cam of a single-spindle automatic screw machine.  On 

some models, it also replaces the Rapid Pull-Out (RPO) mechanism.  After it 

is programmed, the ServoCam® actuator drives the turret slide so as to 

mimic any desired cam profile.  The rest of the screw machine operates 

exactly as it would with a conventional turret-slide cam installed. 

 

The optional AutoTripper™ system replaces the trip dogs for the tool 

turret, the feeder/chucker, the spindle clutch, and the base clutch.  It also 

controls the part deflector on some models.  All trip points are “set” 

automatically when the program is loaded in the controller. 

 

The ServoCam® UltraTurn™ CL system extends this further by adding 

controls for the front cross slide, the front vertical slide, the rear cross slide, 

the rear vertical slide, and the spindle axis. This provides full CNC control 

of all aspects of the machine operation. With this system, there are no feed 

gears to change, no spindle gear changes, and no cam changes. This keeps 

the machine set-up time to a minimum, and provides for easy 

experimentation with feed rates, and cycle times. 

 

The ServoCam® UltraTurn™ XL system extends this even further by 

removing the right rear bracket, and adding a servo control to the turret 

indexer. With this system, the turret can index both forwards and backwards. 

The indexer can also skip stations, so that re-using a tool anywhere in the 

turret does not come with a large time penalty. Also, the XL system supports 

the no-transmission machine setup, by using a belt drive from the spindle 

servomotor directly to the spindle tube. We call this a ‘Fixed-ratio drive’ 

since there is still a gear reduction between the drive motor and the spindle, 

but there is no clutch to shift. 
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Version History 
Version 3.20h was the last release of the UltraSlide™ (Turret or Turret & 

AutoTrippers™) only software. 

 

Version 4.80u was the last release of the UltraTurn™ only software. 

 

Version 5.20 now combines the two products into one common software 

version. The ServoCam® Deisgner™ application can be used to program 

cams for the UltraSlide™ as well as the UltraTurn™ systems. 

 

This manual is intended to describe this most recent software version.  

Currently this manual mostly describes the programming of the turret slide. 

Because this aspect is common to all of the machine options, the turret slide 

programming is a fundamental. As time goes on, more information will be 

added to describe the UltraTurn™ cross slide programming, as well and the 

spindle programming. Also,  
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Safety Warnings and Information 
 

 

The ServoCam® system replaces only the turret-slide cam of the automatic screw machine.  It 

is VERY IMPORTANT that you and all operators read and follow ALL operating 

instructions and safety warnings pertaining to the automatic screw machine to which the 

ServoCam® system is attached. 

 

NEVER REMOVE OR DISABLE ANY SAFETY GUARDS OR FEATURES from the 

ServoCam® system or the automatic screw machine to which the ServoCam® system is 

attached. 

 

IN CASE OF EMERGENCY OR MACHINE MALFUNCTION, IMMEDIATELY 

PRESS THE LARGE RED TOOL STOP BUTTON ON THE FRONT OF THE 

SERVOCAM® CONTROLLER.  NOTE THAT DEPRESSING THE TOOL STOP 

BUTTON DOES NOT REMOVE POWER FROM THE AUTOMATIC SCREW 

MACHINE DRIVE MOTOR OR ACCESSORY MOTORS.  DO NOT RELEASE THE 

TOOL STOP BUTTON UNTIL CONFIRMING THAT ALL PERSONNEL ARE 

CLEAR OF THE AUTOMATIC SCREW MACHINE. 

 

THE SERVOCAM® SYSTEM MAY AT ANY TIME CAUSE THE TURRET SLIDE 

TO MOVE UNEXPECTEDLY, EVEN IF THE AUTOMATIC SCREW MACHINE 

CLUTCH IS DISENGAGED.  ALWAYS DEPRESS THE LARGE RED TOOL STOP 

BUTTON ON THE FRONT OF THE CONTROLLER BEFORE PLACING YOUR 

HANDS OR FINGERS ANYWHERE NEAR THE TURRET SLIDE, TURRET, OR 

WORKPIECE. 

 

ONLY PERMIT QUALIFIED PERSONNEL TO SERVICE OR ADJUST THE 

SERVOCAM® SYSTEM.  EXERCISE CARE WHEN MAKING CHECKS, TESTS, 

AND ADJUSTMENTS THAT MUST BE MADE WITH POWER ON.  FAILURE TO 

OBSERVE THESE PRECAUTIONS CAN RESULT IN INJURY OR DEATH. 
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ServoCam®  
Systems 

The ServoCam® UltraSlide™ system includes the following subsystems: 

• An actuator to drive the turret slide.  The actuator incorporates a brushless 

DC servomotor and a ball screw drive. 

• A 32-bit PC-based controller, packaged in a NEMA 12 enclosure.  The 

user interface includes a four-line display and keypad.  Part cycle 

programs are loaded into the controller on a floppy diskette.  

• A camshaft position monitor. 

• A camshaft override device.  This allows the ServoCam® controller to 

disable camshaft rotation. 

• Windows software for programming part cycles on a personal computer. 

The ServoCam® UltraSlide™ and AutoTripper™ system includes 

everything of an UltraSlide™ system, plus a control board, an air regulator, 

an air pressure interlock switch, and electro-pneumatic actuators for the 

following: 

• Tool turret tripper 

• Feeder/chucker tripper 

• Spindle clutch tripper 

• Base clutch (4-speed machines) 

• Part deflector (on some models) 

 

The base ServoCam® UltraTurn™ system includes everything of an 

UltraSlide™ and AutoTripper™ system, minus the camshaft position 

monitor, plus the following subsystems: 

• Three phase Power filtering and distribution. 

• Brushless AC servomotor to drive the front and front vertical slides. 

• Brushless AC servomotor to drive the rear and rear vertical slides. 

• Brushless AC servomotor to drive the spindle transmission. 
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Principle of Operation 
A conventional cam serves two main functions: 

• As the camshaft rotates, the shape of the cam dictates the motion of the 

tool slide.  Because the cam is attached directly to the camshaft, the tool 

slide always stays synchronized with everything else that is timed by the 

camshaft. 

• The cam actually transmits, from the camshaft, the mechanical power 

necessary to drive the tool slide. 

 

The ServoCam® system is more versatile than a conventional cam because: 

• The motion profile of the tool slide is stored as a computer data file, 

allowing the profile to be changed quickly and easily. 

• The mechanical power to drive the tool slide comes from an electric 

servomotor, not from the camshaft. However, some systems have a 

camshaft position sensor, so the ServoCam® controller can exactly 

synchronize the tool slide position with the camshaft position. 
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Using the ServoCam® 
System 

Three main steps must be followed to set up the turret-slide axis when using 

a conventional cam: 

1. Lay out the turret-slide cam 

2. Fabricate the turret-slide cam 

3. Install the turret-slide cam 

 

With the ServoCam® system, there is no need to fabricate a cam.  The steps 

are: 

1. Design a part cycle with the included ServoCam® Designer software 

2. Set up the ServoCam® controller 

 

Think of the part cycle design software as cam layout software.  To make the 

design process as fast and easy as possible, the software does many routine 

calculations for you.  For example, when you specify a tool feed rate in 

terms of inches per spindle revolution, the software performs all the 

necessary calculations.  A part cycle, therefore, contains all the spindle 

speeds, tool lengths, and other information you enter, as well as the resulting 

turret-slide cam profile.  

Finally, the ServoCam® system allows you to make automatic tool length 

adjustments with simple numeric entries. For example, you might make a 

test part and find that one of the turret tools must be lengthened by 0.023 

inches.  Simply bring up the Tool AutoAdjust menu on the ServoCam® 

controller, select the tool, and enter the adjustment.  You can make 

adjustments to a resolution of 0.0001 inches or 0.001 millimeters. See 

Chapter 4 for more information about setting up the ServoCam® controller. 
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ServoCam® Coordinate 
System 

 

 

 

 

Figure 1-1 illustrates the coordinate system conventions used with the 

ServoCam® system. 

To simplify part cycle design with the ServoCam® Designer software, 

turret-slide operations are programmed by specifying tool positions with 

respect to the workpiece.  To be more precise, the part cycle designer 

specifies the positions of the Tool Reference Point(s) with respect to the 

Workpiece Reference Point.  Given these reference points, the software can 

determine the proper turret-slide positions. 

 

Figure 1-1:  ServoCam® Turret Coordinate System
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Workpiece Reference Point 
The Workpiece Reference Point can be placed anywhere on (or even off) the 

workpiece, but is generally placed on the edge of the finished part.  For 

example, if a part drawing gives all part length dimensions with respect to a 

single reference surface, it is usually easiest to place the Workpiece 

Reference Point on that reference surface.  It is also commonly placed at the 

end of the workpiece. 

Distance from Spindle Face to Workpiece 
Reference 

The ServoCam® system must know the position of the Workpiece Reference 

Point with respect to the screw machine itself.  Therefore, the Distance from 

Spindle Face to Workpiece Reference Point must be specified by the part 

cycle designer. 

Tool Reference Point 
The Tool Reference Point for a given tool can be placed anywhere on that 

tool.  It is usually best to place it at a major cutting edge of the tool—the tip 

of a drill, for example.  For tools without a well-defined cutting edge (such 

as a tap or feed stop), the Tool Reference Point is usually placed at the end 

of the tool. 

Tool Length 
For each tool, the ServoCam® system must know the position of the Tool 

Reference Point with respect to the tool turret.  Tool Length is the distance 

from the Tool Reference Point to the tool holder, and must be specified by 

the part cycle designer. 

Tool Holder Length 
Tool Holder Length is the distance from the end of the tool holder to the tool 

turret, and must be specified by the part cycle designer. The total of the Tool 

Length & the Tool Holder Length is used to define the location of the Tool 

Reference Point with respect to the tool turret. 

Tool Position 
The Tool Position is the position of the Tool Reference Point with respect to 

the Workpiece Reference Point.  The Tool Position can either be positive or 

negative and is dependent upon the specified Coordinate System. 

 

 

 

(see next page) 
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Coordinate System 

An option is provided to specify the Coordinate System for tool positions.  

Choose a left-handed coordinate system for positive tool positions to be on 

the left side of the Workpiece Reference Point.  Alternatively, choose a 

right-handed (CNC) coordinate system for positive tool positions to be on 

the right side of the Workpiece Reference Point.  Figure 1-1 shows a 

situation where the Tool Position is negative for a left-handed coordinate 

system and positive for a right-handed coordinate system. 

Turret Adjustment Screw Setting  
For ServoCam®-equipped machines that retain the turret-slide position 

adjustment screw, the turret adjustment screw setting indicates how the 

physical turret-slide adjustment should be set.  It is zero when the adjustment 

screw is set to move the turret as close as possible to the spindle.  For all 

other positions, the Turret Adjustment Screw Setting is a positive number.  

(The turret adjustment screw is not shown in Figure 1-1.) 
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Workpiece Reference Point 
For the cross slides, the spindle center line is used as Workpiece Reference 

Point. 

Tool Reference Point 
The Tool Reference Point for a given tool can be placed anywhere on that 

tool.  It is usually best to place it at a major cutting edge of the tool—the tip 

of a drill, for example.  For tools without a well-defined cutting edge (such 

as a tap), the Tool Reference Point is usually placed at the end of the tool. 

Tool Length 
For each tool, the ServoCam® system must know the position of the Tool 

Reference Point with respect to the center line of the T-slot.  Tool Length is 

the distance from the Tool Reference Point to the tool holder, and must be 

specified by the part cycle designer. 

Tool Holder Length 
Tool Holder Length is the distance from the end of the tool holder to the 

center line of the T-slot on the cross slide, and must be specified by the part 

cycle designer. The total of the Tool Length & the Tool Holder Length is 

used to define the location of the Tool Reference Point with respect to the 

center line of the T-slot. 

Tool Position 
The Tool Position is the position of the Tool Reference Point with respect to 

the Workpiece Reference Point.  The Tool Position can either be positive or 

negative and is dependent upon the specified Coordinate System. 

Figure 1-2:  ServoCam® UltraTurn™ Cross Slide Coordinate System
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Coordinate System 
An option is provided to specify the Coordinate System for tool positions.  

Choose a left-handed coordinate system for positive tool positions to be on 

the left side of the Workpiece Reference Point.  Alternatively, choose a 

right-handed (CNC) coordinate system for positive tool positions to be on 

the right side of the Workpiece Reference Point.  Figure 1-2 shows a 

situation where the Tool Position is negative for a left-handed coordinate 

system and positive for a right-handed coordinate system. 

Adjustment Screw Setting  
The slide adjustment screw setting indicates how the physical slide 

adjustment should be set.  It is zero when the adjustment screw is set to 

move the slide as close as possible to the spindle.  For all other positions, the 

Slide Adjustment Screw Setting is a positive number. 

When laying out a part cycle, remember, the machine must be set-up to 

match this slide adjustment setting. If the machine is not set-up as shown on 

the set-up sheet, then the tool with either not reach far enough, or worse, the 

tool will plunge into the workpiece. Be very sure that you understand the 

importance of communicating the need to have the machine adjustment 

actually match the value that is used in the part cycle layout !!! 
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Figure 1-3:  ServoCam® UltraTurn™ Vertical Slide Coordinate System
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Chapter 2  Specifying Tool Operations 
 

 

Introduction 
Designing a turret-slide cam may seem difficult at first, but the ServoCam® 

Designer software makes it simple. 

The software does all the computationally intensive steps for you.  You 

simply specify tool motion with respect to the workpiece.  With ServoCam® 

Designer software, any part cycle can be designed using no more than five 

types of tool motion operations. 

In order for the ServoCam® Designer software to do the detailed 

calculations for you, it needs some basic information about the part cycle: 

• What tools are in the tool turret? 

• How long are the tools? 

• What spindle speeds are being used? 

• How far does the workpiece extend from the spindle collet? 

 

Although this manual shows this information being entered in a specific 

order, you can enter this information in any order you choose.  However, 

the software might not be able to complete some calculations until you 

enter all the required information. 

Figure 1-1 shows the coordinate system conventions used with the 

ServoCam® Designer software. 

You can assign the Workpiece Reference to be anywhere on (or off) of the 

workpiece.  It is often easiest to place the reference at the end of the 

workpiece. 

Likewise, you can assign the Tool Reference to be anywhere you want on 

each tool.  It is usually placed at a major cutting edge of the tool (the tip of a 

drill, for example).  With the coordinate system references assigned, you can 

specify tool positions with respect to the workpiece for any tool motion 

operation, and the computer computes the necessary turret-slide position for 

you. 
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Start the ServoCam® 
Designer Software 

1. Open the ServoCam® Designer software application. 

2. The ServoCam® Designer application window appears with the 

ServoCam® logo on top for a few seconds. 

 

3. After the ServoCam® logo disappears, you may begin using ServoCam® 

Designer. 

 

(see next page)
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Set Preferences 
For information that will not likely change from part cycle to part cycle, the 

ServoCam® Designer software provides a Preferences window.  From this 

window, you can set the default values for some of the part cycle 

information.  These defaults will apply to every new part cycle created. 

To set or change the preferences, select File->Preferences from the menu 

located at the top of the ServoCam® window.  

 

1. Enter the name of your company in the Company field. 

2. If the same person will design most part cycles, enter that person’s name 

in the Designer field. 

3. If most part cycles will run on the same machine, enter that machine 

identification in the Machine Id field. 

4. Select the Unit of Length you typically use. 

5. Select the type of Coordinate System you would like to use. 

6. Select the Machine Model that most part cycles will run on. 

7. Select the Speed Rating for the machine that most part cycles will run 

on. 

8. Select the number of Spindle Capacity you will most typically use. 

9. Select the number of Spindle Transmission you will most typically use. 

10. Select the number of Tool Stations that you typically use. 

11. If you have any ServoCam®-equipped machines that retain the turret-

slide position adjustment screw, enter a position setting in the Turret 

Adjust field.  If in doubt, 0.5 inches (or 13 mm) is suggested. 

12. Select the Backshaft Speed that you most commonly use. 

13. When you are finished entering information on this screen, click 

. 

For more information about 

the coordinate system, see 

the ServoCam™ coordinate 

information provided in 

Chapter 1. 
For more information about 

Machine Type, see the Setup 

section of this chapter. 
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Create & Save 
a New File 

1. To create a new file, select File->New from the ServoCam® menu 

located at the top of the ServoCam® window. 

2. ServoCam® opens a new cam file. 

 

3. Save this new file by selecting File->Save from the ServoCam® menu.  

Since this file has not yet been saved, the Save As dialog box appears. 

 

4. In the Save in field, click on the down arrow, then select the folder in 

which you want to save the file. 

5. Enter the name you wish to give the file in the File name field. 

6. Click . 
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Setup Button 
Once you name and save your new cam file, you are ready to design a new 

cam.  When you click on the Setup button, the following window appears: 

 

1. Enter the name of your company in the Company field. 

2. Enter your name in the Designer field as the part cycle designer. 

3. Enter the date into the Design Date field. 

4. Enter the drawing number in the Drawing # field. 

5. Enter a short description of the part cycle you are designing in the 

Description field. 

6. Enter the part material in the Material field. 

7. Enter your machine identification description in the Machine Id field. 

8. Select the Unit of Length you would like to use.  This setting applies 

throughout the part cycle. 

9. Select the type of Coordinate System you would like to use. 

10. Select the Machine settings for the machine that this part cycle will run 

on. 

11. Enter the desired distance from the spindle face to the workpiece 

reference in the Distance from Spindle Face to Workpiece Reference 

field. 

12. Enter any other useful notes or information in the Notes field. 

13. When you are finished entering information on this screen, click 

 to save your changes.  Otherwise, click  to 

discard your changes. 

For more information about 

the coordinate system and 

workpiece references, see 

the ServoCam™ coordinate 

information provided in 

Chapter 1. 

The machine type specifies 

the screw machine model to 

be used, as well as 

ServoCam™ actuator 

performance options.  Click 

the Help button for a 

complete list of supported 

machine types. 
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Spindle Button 
After you enter the necessary information in the Setup window, click on the 

Spindle button, and the following window will appear: 

 

The spindle speed is needed in order to determine the proper turret-slide 

motions for any parameter specified in terms of spindle revolutions (feed 

rate and dwell duration). 

1. In the Speeds section, use the drop-down list to specify any Brake-in-

Neutral to be used in the part cycle. 

2. Select the first Speed field and type in the desired speed. 

3. After you enter all desired speeds, enter the direction of the spindle in 

the corresponding Direction fields.  To do this, click on the down arrow 

of the appropriate Direction field and select Forward or Backward.  

 

4. When you are finished entering information on this screen, click 

 to save your changes.  Otherwise, click  to 

discard your changes. 

Spindle Brakes on L-to-H 

means that the Neutral plug 

that is between the Low and 

High pocket in the spindle 

dog clutch must be removed.  

If the spindle clutch is in Low, 

a “trip” will cause it to go to 

Neutral. 

 
Spindle Brakes on H-to-L 

means that the Neutral plug 

that is between the High and 

Low pocket in the spindle dog 

clutch must be removed.  If 

the spindle clutch is in High, 

a “trip” will cause it to go to 

Neutral. 

Click the  

button to view the spindle 

speed charts for most B&S 

screw machine models. 
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Tool Turret Button 
After you enter the necessary information in the Spindle window, click on 

the Tools button, and the following window will appear: 

 

1. In the # Tool Stations field, indicate the number of tool stations your tool 

turret supports.  Click on the radio button corresponding to either six or 

eight tool stations. 

2. If the tool turret should be configured for double indexing, click the 

Double Indexing check box. 

3. If applicable, enter a setting for the turret-slide position adjustment 

screw in the Turret Adjust field.  If in doubt, 0.5 inches (or 13 mm) is 

suggested. 

4. Enter the maximum tool AutoAdjust value in the Maximum Tool 

AutoAdjust field.  If you do not enter a dimension, the software will 

enter a default value for you. 

5. Double-click on tool station #1 to open the tool editing window titled 

Tool: 

 

6. Enter the name of the tool in tool station #1 in the Description field. 

7. Enter the tool length in the Tool Length field.  

8. Enter the tool holder length in the Holder Length field. The software will 

use the Tool Length plus the Holder Length to determine distances from 

the face of the tool turret. 

9. When you are finished, click . 

10. Repeat Steps 5-8 for each tool station being used in this part cycle. 

For more information about 

tool length, see the 

ServoCam™ coordinate 

information provided in 

Chapter 1. 

Turret Adjust should be 

between 0 and 1 inch (0 and 

25.4 mm). 

 

For more information about 

turret adjust dimensions, see 

the ServoCam™ coordinate 

information provided in 

Chapter 1. 

Maximum Tool AutoAdjust is 

the maximum automatic tool 

length adjustment that can be 

made at the ServoCam™ 

controller.  The ServoCam™ 

Designer reserves the 

amount of turret-slide travel 

necessary for the specified 

Maximum Tool AutoAdjust.  

Using a large maximum 

AutoAdjust reduces the tool 

slide travel available for 

machining operations, and 

slightly increases cycle time. 
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11. After you enter all tool data, review the Tool Turret Table to confirm 

that all tool data has been entered correctly. 

12. When you are finished, click  to save your changes.  

Otherwise, click  to discard your changes. 

Moving Tool Data 
To move tool data from one station to another: 

1. Highlight the tool station to be moved. 

2. Click the  button to move the tool data up one station, or click the 

 button to move the tool data down one station. 

You can move blank lines in 

the same way as lines 

containing data. 
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Editing Tool Data 
To edit tool data: 

1. Double-click on the tool station to be edited, OR from the menu, select 

Edit, then select Edit Tool.  The Tool window will appear: 

 

2. Modify as necessary, then click . 

Clearing Tool Data 
To clear tool data: 

1. Highlight the tool station to be cleared. 

2. From the menu, select Edit, then Clear Tool. 

Using Multi-use Tool Stations 
Each tool station starts, by default, as a single-use tool station.  This means 

that only one tool will be in that station, and it will be used for only one 

operation in the part cycle.   

If you have any turret tool stations that will hold more than one tool or if any 

tool will be used for more that one operation in the part cycle, you can make 

that station a multi-use tool station as follows: 

1. Highlight the appropriate tool station. 

2. From the menu, select Edit, then select Make Multi-use. 

You will notice that an extra line has been added to the entry for this tool 

station as shown below for tool station #1: 

 

The original tool data – “STOCK STOP” of 3.5000 inches – now becomes 

tool #1a, and an empty tool labeled tool #1b has been added. 

Double-click on a multi-use tool station and a window with the title Station 

will appear:  
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This window is similar to the Tool Turret window, except it represents only 

the tools in the multi-use station.  To specify the list of tools in this multi-use 

tool station, use the Insert, Edit, Cut, Copy, and Paste menu items. 

The Insert menu item adds a new tool to the list.  The highlight bar should 

be placed on the row where the new tool is to be inserted.  If there is already 

a tool in the highlighted row, a new row will be inserted just before the 

highlighted row. 

The Edit menu item opens the tool edit window.  Modify the tool 

information as necessary, then click . 

The Cut menu item deletes the highlighted tool from the list and saves the 

tool data for use by the Paste menu item. 

The Copy menu item takes a copy of the highlighted tool and saves it for use 

by the Paste menu item. 

The Paste menu item inserts into the list the most recent tool that was saved 

by either Cut or Copy. 

For instance, if you need to use the same stock stop for two stock feed 

operations, you may create a multi-use tool station with the stock stop 

represented twice, as shown below:  

 

The advantage to doing this is that you will now have a separate Tool 

AutoAdjust on the ServoCam® controller for each use of the tool. 

When you are finished with the Station window, click  to save 

your changes.  Otherwise, click  to discard your changes. 
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Cross-Slides Button 
After you enter the necessary information in the Tool Turret window, click 

on the Cross-Slides button, and the following window will appear: 

 

This window allows you to describe the operations of up to four cross slides.   

On the Cross Slide Info window, you can see the summary information of 

each of the cross slides.  The information shown here will also be printed on 

the ServoCam® Layout Sheet for the setup person. 

To specify a particular cross slide, pick a particular lobe to edit, and click the 

corresponding  button on the Cross Slide Info window.  This will 

launch the Cross-Slide Calculator window, which is described below. 

Click  after you have entered all the desired information in this 

window.  Otherwise, click  to discard your changes. 
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Cross-Slide Calculators 
The ServoCam® Designer software provides cross-slide calculators to help 

specify cross-slide cams.   

To use the calculator for a particular cross slide, click the corresponding 

 button on the Cross Slide Info window.  The Cross-Slide 

Calculator window appears. 

 

Start in the upper section, Ideal Cam Calculator, by specifying the desired  

motions of the cross-slide tool.  The Ideal Cam Calculator then computes 

the parameters for a cam that would satisfy these ideal specifications.  From 

this information, you can decide whether you prefer to have a custom cam 

made or if you wish to use a pick-up cam.   

The lower section, Physical Cam, allows you to enter the actual specification 

of the physical cam that will be used. 

When you are finished with the calculator, click  to save your 

changes.  Otherwise, click  to discard your changes. 

The cross-slide drawings on 

the main window of 

ServoCam™ Designer and 

the cross-slide information 

printed on the Layout Sheet 

are based on the information 

in the Physical Cam section 

only. 
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Using the Ideal Cam Calculator Section 
1. The Desired Cycle Period is displayed at the top of the calculator 

window.  It is used for computing cross-slide hundredths. 

2. Specify the Spindle Speed for the cross-slide operation.  The spindle 

speed must be selected in order to compute spindle revs. 

3. In the Feed 1 row, enter the initial Throw and Feed Rate. 

4. If the cross-slide operation requires a secondary feed rate, click the 

check box next to the Feed 2 row and enter the Throw and Feed Rate.  

Otherwise, un-check the Feed 2 check box. 

5. If the cross-slide operation requires a dwell, click the check box next to 

the Dwell row and enter the number of Revs.  Otherwise, un-check the 

Dwell check box. 

6. Enter the starting hundredths for Feed 1 in the From column.  Generally, 

you should specify the turret-tool operations and select the Desired 

Cycle Period before finalizing this number. 

7. If the cross-slide operation requires a cutdown, enter it in the Cutdown 

field. 

8. If you wish to specify the number of hundredths the cam should take for 

rapids, enter this in the Rapid field. 

As you enter the required information, the calculator computes the duration 

in spindle revs, seconds, and hundredths.  The calculator also computes lead 

– the cam rise divided by cam hundredths.  (A pick-up cam with the same 

lead gives the same feed rate.) 

It is usually best to use the 

cross-slide calculator in 

stages, as follows: 

First, before you know your 

total cycle period, calculate 

cross-slide duration in terms 

of seconds and spindle revs. 

Next, proceed to the Lead 

Cam window.  Reserve the 

appropriate amount of time 

for the cross-slide operations, 

overlapping them with turret-

tool operations where 

appropriate. 

Finally, after selecting the 

cycle period, return to the 

cross-slide calculator.  

Specify the starting 

hundredths, and (optionally) 

evaluate pickup cams. 
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Using the Physical Cam Section 
The information in the Physical Cam section is what gets displayed on the 

Cross Slide Info window, on the Layout Sheet, and plotted on the main 

window.  If you will be using a custom cam based on the information in the 

Ideal Cam Calculator section above, then click the Copy to Physical Cam 

button.  This will transfer all of the ideal specifications down to the physical 

specifications. 

Otherwise, you can use the Physical Cam section as a Pick-Up Cam 

Evaluator.  This will allow you to compare the ideal cross-slide cam to your 

existing cross-slide cams.  The evaluator will help you determine if a given 

pick-up cam is suitable for the part cycle. 

1. Select a small number of candidate pick-up cams, using the guidelines 

shown on the left. 

2. In the Feed 1 row, enter the initial Throw and Duration (Hdths) of a 

candidate pick-up cam. 

3. If the pick-up cam has a secondary feed rate, click the check box next to 

the Feed 2 row and enter the Throw and Duration (Hdths).  Otherwise, 

un-check the Feed 2 check box. 

4. If the pick-up cam has a dwell, click the check box next to the Dwell row 

and enter the Duration (Hdths).  Otherwise, un-check the Dwell check 

box. 

5. Enter the initial hundredths for Feed 1 in the From column. 

6. Inspect the throws, feed rates, and timing of the pick-up cam to evaluate 

its suitability for the part cycle. 

The pick-up cam evaluator is 

best used after you’ve 

narrowed down your search 

to a handful of cams.  Use 

these guidelines to narrow 

your search: 

√ The Total throw of the 

cam must be at least as 

much as the desired 

throw. 

√ The Lead of the cam must 

be close to the desired 

lead.  (Lead = Throw ÷ 
Hdths) 

√ Try a cam designed for a 

similar cycle period. 

If you have a database or list 

of pick-up cams, include the 

Lead of each cam in the list.  

This will make it easier to 

quickly compare them with 

the desired lead. 
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Operations Button 
After you enter the necessary information in the Cross-Slides window, click 

on the Operations button, and the following window will appear:  

 

The operation list will initially be empty.  The menu at the top of the 

Operations window allows you to add to and modify the operation list. 

Turret Slide Design Overview  
1. If you have a rough estimate of the part cycle time, then select a 

preliminary Desired Cycle Period by clicking on the gear picture next to 

the value field for the Desired Cycle Period.  Otherwise, wait until step 

4. 

2. Add all turret-slide operations to the operation list – specifying the 

details of each operation. 

3. Be sure to reserve the appropriate amount of time for the cross-slide 

operations, overlapping them with turret-slide operations where 

appropriate.  This is done by adding time in Clear/Index, Dwell, or 

Position operations, or by decreasing feed rates in Feed In or Feed Out 

operations.  (For example, specify the Clear Period of the final 

Clear/Index operation to allow adequate time for cutoff.) 

4. Select a final Desired Camshaft Cycle Period that is approximately 

equal to the Computed Camshaft Cycle Period. 

5. Adjust the duration of individual turret-slide operations in order to make 

the Computed Camshaft Cycle Period exactly equal to the Desired 

Camshaft Cycle Period. 

6. Specify trip positions. 

The Period[revs] and Period 

[secs] columns show the 

duration (in spindle revs and 

seconds respectively) for the 

operation. 

 

The Begin [secs] and Begin 

[Hdths] columns show the 

starting time (in seconds and 

hundredths respectively) for 

the operation. 
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Turret-Slide Operations 
The ServoCam® Designer software enables you to specify all needed tool 

motions by using sequences of five simple operations.  Table 2-1 provides a 

summary of these five operations. 

The Designer software allows the operations to be used only in certain 

combinations.  Table 2-1 and Figure 2-1 show the proper ordering of turret-

slide operations. 

To specify the list of turret-slide operations, use the menu items Insert, 

Edit, Cut, Copy, Paste, and Delete-All. 

The Insert menu item adds a new operation to the operation list.  The 

highlight bar should be placed on the row where the new operation is to be 

inserted.  If there is already an operation in the highlighted row, a new row 

will be inserted just before the highlighted row. 

The Edit menu item opens the edit window of the highlighted operation. 

The Cut menu item deletes the highlighted operation from the operation list 

and saves the operation for use by the Paste menu item. 

The Copy menu item takes a copy of the highlighted operation and saves the 

copy for use by the Paste menu item. 

The Paste menu item inserts into the operation list the most recent operation 

that was saved by either the Cut or Copy menu items. 

The Delete-All menu item deletes all operations from the operation list. 

Cutting Experts 
Another way to specify turret-slide operation is by using the ServoCam® 

Designer Experts.  Click the Run Experts menu item to see the available 

list.  See the ServoCam® Designer Help File for more information. 
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Table 2-1.  Table of Turret-slide Operations. 

Operation Description Subsequent 

Operation 

Clear/Index Generates rapid moves between metal-cutting 

operations.  Used to clear the tools for a turret 

index, and for rapid pull-outs during a peck-drill 

cycle.  (Essentially, this operation creates the 

“valley” between adjacent “lobes” of the cam.) 

• Feed In 

• Position 

Position Places a tool in a fixed position with the highest 

possible accuracy.  Used for feed-stop, 

recessing, and other stationary operations. 

• Clear/Index 

• Feed Change 

• Dwell 

Feed In Begins feeding a tool toward the collet at a 

specified rate.  Used for most metal-cutting 

operations. 

• Clear/Index 

• Feed Change 

• Dwell 

Feed Change Changes feed-rate of a tool either toward or 

away from the collet.  Used for withdrawing 

taps, feeding out reamers, etc. 

• Clear/Index 

• Feed Change 

• Dwell 

Dwell Holds tool position after a Feed operation.  Lets 

the tool clean up the cut before withdrawing. 
• Clear/Index 

• Feed Change 

• Dwell 

 

, then the next operation may be a…  

Clear/ 

Index 

Position Feed In Feed 

Change 

Dwell 

Clear/Index  X X   

Position X   X X 

Feed In X   X X 

Feed Change X   X X 

If 
previous 
operation 

is a… 
Dwell X   X X 

Figure 2-1:  Proper Ordering of Turret-slide Operations. 



ServoCam™ User’s Manual 

30 

Position Operation 
1. To add a Position operation, select Insert from the menu bar.  Select the 

Position operation. 

The Position window appears.  

 

2. Select the appropriate tool by clicking on the down arrow in the Tool 

field, then clicking on the desired tool. 

3. Enter the final position of the tool in the Final Position field. 

4. Specify the duration as a combination of seconds, camshaft hundredths, 

and spindle revolutions.  Use only the ones you need, and leave the 

others blank. 

5. If you specified any of the duration in terms of spindle revolutions, then 

select the desired spindle speed in the Spindle Speed field. 

6. Enter any notes or comments in the Comment field. 

7. When you are finished, click . 
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Feed In Operation 
1. To add a Feed In operation for a tool, select Insert from the menu bar.  

Then select the Feed In operation. 

The Feed In window appears.  

 

2. Select the appropriate tool by clicking on the down arrow in the Tool 

field, then clicking on the desired tool. 

3. In the box containing the Initial Position, Throw, and Final Position 

fields, specify the parameter to be automatically calculated by clicking 

its radio button. 

4. Specify values for the remaining parameters in their adjacent text boxes. 

5. Select whether you wish to specify feed rate in terms of spindle revs or 

seconds. 

6. Enter the desired feed rate in the Feed Rate field. 

7. Select the desired spindle speed in the Spindle Speed field, if 

appropriate. 

8. Enter notes or comments in the Comment field. 

9. When you are finished, click . 

Any Feed In operation 

includes an initial position, a 

throw, and a final position.  

You must specify two of 

these parameters—the 

software automatically 

calculates the third 

parameter.  To choose the 

parameter to be calculated, 

click its radio button. 
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Dwell Operation 
1. To add a Dwell operation, select Insert from the menu bar.  Select the 

Dwell operation. 

The Dwell window appears. 

  

2. Specify the dwell duration as a combination of seconds, camshaft 

hundredths, and spindle revolutions.  Use only the ones you need, and 

leave the others blank. 

3. If you specified any of the duration in terms of spindle revolutions, then 

select the desired spindle speed in the Spindle Speed field. 

4. Enter any notes or comments in the Comment field. 

5. When you are finished, click . 
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Feed Change Operation 
1. To add a Feed Change operation, select Insert from the menu bar.  Then 

select the Feed Change operation. 

The Feed Change window appears.  

 

2. Select the Direction as either In (toward the collet) or Out (away from 

the collet). 

3. In the box containing the Throw and Final Position fields, specify the 

parameter to be automatically calculated by clicking its radio button. 

4. Specify a value for the remaining parameter in its adjacent text box. 

5. Select whether you wish to specify feed rate in terms of spindle revs or 

seconds. 

6. Enter the feed rate in the Feed Rate field. 

7. Select the desired spindle speed in the Spindle Speed field, if 

appropriate. 

8. Enter any notes or comments in the Comment field. 

9. When you are finished, click . 

A Feed Change operation 

gets its initial position from 

the preceding operation.  

When you specify a throw or 

final position, the software 

automatically calculates the 

remaining parameter.  To 

choose the parameter to be 

calculated, click its radio 

button. 

The Feed Out operation has 

been replaced with the Feed 

Change operation.  

Previously, a Feed Out 

operation was used to feed 

the turret away from the collet 

after a Feed In.   

 

Now, using a Feed Change, 

you can change the feed rate 

any number of times, either 

toward or away from the 

collet. 
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Clear/Index Operation 
1. To add a Clear/Index operation, select Insert from the menu bar.  Then 

select the Clear/Index operation. 

The Clear/Index window appears.  

 

2. Use the Clear Position of Previous Tool field to specify the clear 

position of the tool used in the previous operation.  If you do not specify 

this field, the software assumes that the final position of the tool is clear. 

 

IMPORTANT: When indexing, the tool must be clear of the workpiece 

at the specified Clear Position. 

3. If you want to increase the clear period, specify a value in the Minimum 

Clear Period section.  Use the fields for seconds, spindle revolutions, or 

camshaft hundredths to add the needed amount of clear time. 

4. Use the Clear Position of Next Tool field to specify the clear position of 

the tool used in the next operation.  If you do not specify this field, the 

software assumes that the initial position of the tool is clear. 

 

IMPORTANT: When indexing, the tool must be clear of the workpiece 

at the specified Clear Position.  If no index will occur, as when peck-

drilling, you do not need to specify this field. 

5. Enter notes or comments in the Comment field. 

6. When you are finished, click . 

The Clear/Index operation 

generates rapid moves 

between metal-cutting 

operations, as follows: 

1) A rapid move out to the 

turret slide clear position.  

This rapid out is kept as short 

as possible, while ensuring 

that the tools move to or 

beyond their clear positions. 

2) A dwell of the specified 

period.  (This is useful for 

idling the turret slide during 

cross-slide operations.) 

3) A rapid move in to the 

initial position of the next 

operation. 
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Specify Cycle Period 
After you have specified the turret-slide operations, you are ready to select a 

Desired Cycle Period to match the Computed Cycle Period.  Click the Select 

Cycle Period button (button with a picture of gears), and the following 

window appears:  

 

The camshaft cycle period for a screw machine is determined by the set of  

feed gears chosen.  The ServoCam® Designer software extends the standard 

Brown & Sharpe feed gear table to include most any cycle time possible 

with the standard set of feed change gears. 

To select the appropriate cycle period and gear set: 

1. Specify the Backshaft Speed. 

2. Click the Find Gearset button, and the software will automatically 

highlight the closest cycle period to the Computed Cycle Period.  (You 

can also do this manually by scrolling down the list, then clicking on the 

appropriate cycle period to highlight it.) 

3. If any of the turret operations have a duration specified in Camshaft 

Hundredths, then the Computed Cycle Period will change when you 

change the Desired Cycle Period.  In this case, you must repeat step 2 

until the two match. 

4. When you are finished, click  to save your selection.  

Otherwise click . 

When threading to a shoulder 

or bottom tapping, the 

relative position of the clutch 

teeth at the time of spindle 

reversal should be constant.  

Gear combinations that do 

not satisfy this condition are 

marked with an * in the feed 
gear table. 

When the same cycle period 

can be achieved with multiple 

gear combinations, the 

extended gear table lists 

those gear combinations with 

better load balancing first. 
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Modifying the Feed Gear Table 
You can also add more gear combinations to the table to customize it for 

your needs.  To add or modify a gear set while in the feed gear table: 

1. To add a gear set, click the Add button.  To modify a gear set, highlight 

the appropriate gear set then click the Edit button. 

2. Type in the number of teeth for each gear.  When you have entered a 

complete set, the cycle period for that set is computed. 

3. Select  to save your changes to the gear set, or select 

 to discard the changes. 

4. Repeat steps 1 – 3 as needed. 

5. Select  to save all your changes to the feed gear table, or 

select  to discard all changes. 

Each gear set is numbered within the gear table.  The numbers followed by 

“+” indicate the gear sets which you have added.  Only these custom gear 

sets may be modified or deleted.  The original gear sets may not be modified 

or deleted. 
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Specify Trip Positions 
After you have specified the turret-slide and cross-slide operations, you are 

ready to specify the trip positions for the part cycle.  If you want accurate 

trip-dog settings printed on the ServoCam® Layout Sheet (or if you have an 

AutoTripper™ system), you must specify the trip positions for the part 

deflector, the feeder/chucker, and the spindle clutches.  Additionally you 

may specify the tool turret trip positions, or the ServoCam® Designer can 

compute them automatically. 

Actually, you are not directly specifying the trip positions, but rather the 

desired timing for each machine transition.  The trip position is where the 

trip lever is activated by a trip dog.  The machine transition occurs when the 

mechanism being tripped changes state.   

This is best illustrated using the tool turret as an example.  The process of 

indexing a tool is as follows: 

Trip starts Trip lever is activated, pulling trip 

pin out of slot in the dog clutch 

 Dog clutch engages 

 Backshaft begins to drive the turret 

indexing mechanism 

Transition 

starts 

Turret locking pin is withdrawn 

 Turret rotates to next tool station 

Transition 

ends 

Turret locking pin is replaced 

 Trip pin drops back into slot and 

disengages dog clutch 

Trip ends Turret indexing mechanism is 

reset and ready for another trip 

As you can see, the transition begins some time after the trip lever is 

activated. 

In ServoCam® Designer, you specify where you want the start, the end, or 

the center of each transition to occur within the part cycle.  The Designer 

then computes where the trip-dog should be placed (or the AutoTripper™ 

fired) in order to achieve your specified transition timing. 

 

The trips are specified by using the timeline view for each tripper. If you do 

not see the tripper you want, then either use the ‘View’ menu to show it, or 

click the ‘More’ button. 

Note that after the trip 

positions have been 

specified, any changes to the 

part cycle (particularly the 

cycle period or turret-slide 

operations) could cause the 

trip positions to require 

adjustment. 
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Part Deflector Trip Positions 
1. To specify the trip positions for the part deflector, click the Part 

Deflector button, and the following window appears: 

 

2. To add a trip position to the list, select Insert from the menu, and the 

options will be Idle and Deflecting Part. 

3. Select the desired action, and the edit window will appear. 

 

4. Select the Start, Center, or End of the transition as the transition 

reference point. 

5. In the drop-down list, select whether you wish to specify the transition in 

Camshaft Hdths or Seconds. 

6. In the Transition at field, specify where to locate the transition reference 

point in the part cycle. 

7. When you are finished, click . 

8. Repeat steps 2 – 7 for each action required of the part deflector. 

9. After specifying the part deflector trip positions, click  to 

save your changes, or click  to discard them. 

The part deflector actions 

must come in alternating 

pairs to be valid.  For every 

Deflecting Part, there must 

be a corresponding Idle. 
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Feeder/Chucker Trip Positions 
1. To specify the feeder/chucker trip positions, click the Bar Feeder 

button, and the following window appears: 

 

2. Specify whether the bar feeder mechanism will be in Feeder Mode or 

Chucker Mode. 

3. Specify the Drive-sleeve Speed. 

4. To add a trip position to the list, select Insert from the menu.  If you are 

in Feeder Mode, the only option is Feed.  If you are in Chucker Mode, 

the options are Open and Close. 

5. Select the type of trip you wish to insert (Feed, Open, or Close) and the 

edit window will appear. 

 

6. Select the Start, Center, or End of the transition as the transition 

reference point. 

7. In the drop-down list, select whether you wish to specify the transition in 

Camshaft Hdths or Seconds. 

8. In the Transition at field, specify where to locate the transition reference 

point in the part cycle. 

9. When you are finished, click . 

10. Repeat steps 4 – 9 for each feeder/chucker trip position required. 

11. After specifying the feeder/chucker trip positions, click  to 

save your changes, or click  to discard them. 

When in Chucker Mode, the 

bar feeder actions must come 

in alternating pairs to be 

valid.  For every Open, there 

must be a corresponding 

Close. 
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Spindle Clutch(es) Trip Positions 
1. To specify the trip positions for spindle speed changes, click the Spindle 

Clutch(es) button, and the following window appears: 

 

2. To add a trip position to the list, select Insert from the menu.  If you 

have 2 speeds, the options will be High speed and Low speed.  If you 

have 4 speeds, the options will be High speed, Speed 2, Speed 3, and 

Speed 4. 

3. Select the desired speed, and the edit window will appear. 

 

4. Select the Start, Center, or End of the transition as the transition 

reference point. 

5. In the drop-down list, select whether you wish to specify the transition in 

Camshaft Hdths or Seconds. 

6. In the Transition at field, specify where to locate the transition reference 

point in the part cycle. 

7. When you are finished, click . 

8. Repeat steps 2 – 7 for each spindle speed change required. 

9. After specifying the spindle speed trip positions, click  to 

save your changes, or click  to discard them. 

When tapping, place the 

spindle reversal trip position 

at the same time as the 

beginning of the Tap Out.  

Also select Start as the 

transition reference point. 
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Tool Turret Trip Positions 
1. To specify the tool turret trip positions, click the Turret Trips button, 

and the following window appears: 

 

2. To allow ServoCam® Designer to automatically compute the tool trip 

positions, the Auto-Compute Trips check box must be checked (this is 

the default). 

3. Otherwise, if you prefer to specify the tool trip positions manually, un-

check the Auto-Compute Trips check box and select Insert from the 

menu. 

4. Select the desired tool station, and the edit window will appear. 

 

5. Select the Start, Center, or End of the transition as the transition 

reference point. 

6. In the drop-down list, select whether you wish to specify the transition in 

Camshaft Hdths or Seconds. 

7. In the Transition at field, specify where to locate the transition reference 

point in the part cycle. 

8. When you are finished, click . 

9. Repeat steps 3 – 8 for each tool turret trip position required. 

10. After specifying the tool turret trip positions, click  to save 

your changes, or click  to discard them. 



ServoCam™ User’s Manual 

42 

 

 

Inspect the Cam & 
Verify Results 

After you enter all information to create a cam, ServoCam® Designer checks 

for invalid and missing information.   

Whenever data associated with a particular window is Invalid or Out of 

Range, the Info button on that window turns red.  Also, the Info button will 

turn yellow whenever data associated with a particular window is Valid but 

there is a warning. 

In order to make it easier to find which window has the red (or yellow) Info 

button, the button that launches that window will become red (or yellow) as 

well. 

For instance, if the Turret Slide operations list has data that is Out of Range 

and it’s Info button is red, then the Operations button on the Main window 

will also be red. 
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Save the Cam 
Because you have probably already named and saved your cam file (see 

Create & Save a New File at the beginning of this chapter), you only need to 

perform a normal Save operation: 

1. Select File->Save 

2. The file is automatically saved to the directory in which it was originally 

saved. 

To save the file to a different directory: 

1. Select File->Save As… 

2. In the Save in field, click on the down arrow, then select the folder in 

which you want to save the file. 

3. Enter the name you wish to give the file in the File name field. 

4. Click . 

 

 

Create a Cam Diskette 
The Cam Diskette contains the information about the part cycle which is to 

be loaded into the ServoCam® controller.  To create a Cam Diskette, follow 

these steps: 

1. Insert a formatted 3.5” diskette into your floppy disk drive. 

2. Select File->Make Cam Diskette from the menu at the top of the 

ServoCam® window. 

3. When the operation is complete, remove the diskette from the disk drive. 

If you attempt to make a Cam 

Diskette before saving the 

file, the ServoCam™ 

Designer prompts you to 

save the file first. 
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Preview the Layout Sheet 
ServoCam® software enables you to preview the layout sheet: 

1. Select File->Print Preview from the ServoCam® menu.  The following 

will appear: 

 

2. You can view any of the pages. 

3. You can choose to print a large cam view. 

 

Print the Layout Sheet 
ServoCam® software enables you to print a layout sheet which will help to 

set up the job: 

4. Select File->Print from the ServoCam® menu.  The following Print 

dialog box will appear: 

 

5. Select the desired printer. 

6. Specify the number of copies. 
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7. Check the “Full-page Cam drawing” check box for a full-page printout 

of the cam drawing. 

8. When ready to print, click . 

 

 

Close the File 
After you save the cam and print a layout sheet, you can close the cam file: 

1. Select File->Close from the ServoCam® menu. 

2. Select File->Exit from the ServoCam® menu to exit the ServoCam® 

Designer program. 
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Chapter 3  Completing and Troubleshooting an 
UltraSlide™ Part Cycle Design 

 

 

Overview 
This section describes methods by which you can edit an existing cam, and 

troubleshoot cam design complications. 

 

 

Open the Existing 
Cam File 

1. To open an existing file, select File->Open from the ServoCam®menu 

located at the top of the ServoCam® window.  The Open File dialog 

box appears.  

2. If you want to make a backup copy of the existing file, save the file 

under a different file name.  Select File->Save As from the ServoCam® 

window.  The Save As… dialog box appears. 

After you save a file under a 

different name, the original 

file is no longer active.  

Instead, the file with the new 

name is open in ServoCam™ 

Designer.  
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Cam Drawings 
As the operations for each slide are defined, the Main screen shows a 

drawing, in cam format, of the motions for that slide. 

 

The key in the upper-left corner of the display identifies which “cam” 

drawing is associated with each slide. 

To view the drawing of a particular slide, then check its box in the key.  To 

hide the drawing, then uncheck its box in the key. 

Clicking one of the colored buttons in the key will emphasize the drawing of 

the same color.  Clicking that button again will take the drawing back to 

normal size. 

To view a ruler of hundredths, check the Ruler box. 
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Setup Button 
Click on the Setup button.  The following screen appears: 

 

1. Make all necessary changes to this screen.  For more information about 

the information contained in this screen, refer to Chapter 2. 

The Distance from Spindle Face to Workpiece Reference may be 

adjusted to cause tool operations to be within the range of the turret 

slide.  Increasing this distance is like sliding the workpiece further out of 

the collet. 

The Machine Type / Cam Type affects the maximum turret speed, range 

of travel, and force that the ServoCam® controller will allow for this 

part cycle.  Click the Help button for more information. 

2. When you are finished entering information on this screen, click 

. 
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Spindle Button 
After you enter the necessary information in the Setup window, click on the 

Spindle button, and the following window will appear: 

 

1. Make all necessary changes to this screen.  For more information about 

the information contained in this screen, refer to Chapter 2. 

Speeds given here affect all values which are calculated from spindle 

revolutions (for example, feed rates in inches per spindle revolution). 

Direction is not used for calculations; it is included only for setup 

information. 

2. When you are finished entering information on this screen, click 

. 
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Tool Turret Button 
After you enter the necessary information in the Spindle window, click on 

the Tool Turret button, and the following window will appear: 

 

1. Make all necessary changes to this screen.  For more information about 

the information contained in this screen, refer to Chapter 2. 

The Tool Lengths specified on this screen affect the success of the part 

cycle computations in the same way they affect successful operation of 

the actual screw machine.  For example, you might have a 3.5 inch drill, 

but for the given setup such a drill may not be usable.  Instead, a 3 inch 

drill is required.  The tool lengths interact with other values, such as 

Distance from Spindle Face to Workpiece and Turret Adjust.  Tool 

lengths which are clearly out of range are preceded by an asterisk (*). 

For ServoCam®-equipped machines that retain the turret-slide position 

adjustment screw, the Turret Adjust specifies the setting of that screw.  

Change the setting as necessary to cause tool operations to fall within 

the working travel of the turret slide.  Increasing this distance is like 

moving the tool turret away from the collet.  The specified setting must 

be between 0 and 1 inch (0 and 25.4 mm). 

Maximum Tool AutoAdjust specifies the range reserved for the Tool 

AutoAdjust feature on the controller.  Typically, this value is set to 

approximately 0.1 inch (2.54 mm), which reserves ±0.1 inch (±2.54 mm) 

for adjustment of each tool on the controller.  If this value is very large 

(for example, 1 inch or 25 mm), more adjustment is available for each 

tool, but the range of motion will be reduced accordingly (in this case by 

2 inches or 50 mm)). 

2. When you are finished entering information on this screen, click 

. 
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Cross Slides Button 
After you enter the necessary information in the Tool Turret window, click 

on the Cross-Slides button, and the following window will appear: 

 

Before finalizing the part cycle, verify that each cross-slide is correct and 

contains the necessary information for the setup person. 

1. Be sure to reserve the appropriate amount of time for the cross-slide 

operations, overlapping them with turret-slide operations where 

appropriate. 

2. If the cross-slide drawings or the information printed on the ServoCam® 

Layout Sheet does not seem correct, note that these are based on the 

information in the Physical Cam section of the Cross-Slide Calculator. 

Click  after you have verified the information in this window. 
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Lead Cam Button 
After you enter the necessary information in the Cross-Slides window, click 

on the Operations button, and the following window will appear: 

 

1. Make all necessary changes to this screen.  For more information about 

the information contained in this screen, refer to Chapter 2. 

Operations which are not yet defined (missing some or all information) 

are preceded by a question mark (?), as in ?Dwell.  Operations which 

are out of range are preceded by an asterisk (*), as in *Dwell.  If the part 

cycle is not valid, these operations should be checked.  In some cases, 

the undefined or out of range condition may be caused by a different 

operation, since some operations get values (e.g., initial position) from a 

neighboring operation. 

If two operations cannot appear next to one another (see Table 2-1 and 

Figure 2-1), a placeholder operation is temporarily inserted between 

them.  The placeholder operation is indicated by a special name:  

********.  The placeholder is automatically removed when the 

sequence of operations is made legal by operation insertion or deletion.  

In any case, this situation must be corrected in order for the part cycle to 

be valid.  The simplest approach is to first insert the required operations, 

and then add operations (typically, clear/index) wherever the placeholder 

operation appears. 

2. Spindle Speeds are required only for operations that have a specification 

related to spindle revolutions (like a feed rate or a dwell). 

3. The Desired Camshaft Cycle Period must equal one of the cycle times 

available on the screw machine.  (Refer to your Feed Gear Table.)  

Additionally, when the part cycle design is complete, it must equal the 

Computed Camshaft Cycle Period.  This is accomplished as follows: 

Design the part cycle without any extra delays. 
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a. Set the desired period to the shortest available cycle that is at 

least as long as the computed period. 

b. Add sufficient delays somewhere in the cycle to make the 

computed period equal to the desired period. 

For example, if the part cycle has a computed period of 32.7 seconds 

(which is not available on the screw machine), choose a desired period 

of 35 seconds.  This requires an added delay of 2.3 seconds in another 

operation, such as a Clear/Index operation. 

4. If you make any changes to the turret operations or to the cycle period, 

make sure that your trip settings and cross-slide settings are still correct. 

5. When you are finished entering information on this screen, click 

. 

 

 

Trip Positions 
After the trip positions have been specified, any changes to the part cycle 

(particularly the cycle period or turret-slide operations) could cause the trip 

positions to require adjustment.  To minimize this effect, it is recommended 

to specify trip positions in terms of seconds rather than hundredths. 

The ServoCam® Designer compares the spindle speeds in the turret 

operations list with the list of spindle clutch trip positions.  If they are not 

consistent, then you will be notified with a yellow Info button. 

 

 

Inspect the Cam & 
Verify Results 

After you enter all information to create a cam, ServoCam® Designer checks 

for invalid and missing information.  If it finds any, it displays a red or 

yellow Info button in the windows containing invalid information.  Click on 

these buttons to pinpoint the problem, then provide data in the appropriate 

fields. 

When you are finished, you are ready to save this version of your cam. 
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Save the Cam 
Because you have probably already named or re-named and saved your cam 

file (see Create & Save a New File in Chapter 2), you need only perform a 

normal Save operation: 

1. Select File->Save 

2. The file is automatically saved to the directory in which it was originally 

saved. 

 

To save the file to a different directory: 

1. Select File->Save As…. 

2. In the Save in field, click on the down arrow, then select the folder in 

which you want to save the file. 

3. Enter the name you wish to give the file in the File name field. 

4. Click . 

 

 

Create a Cam Diskette 
The Cam Diskette contains the information about the part cycle which is to 

be loaded into the ServoCam® controller.  To create a Cam Diskette, follow 

these steps: 

1. Insert a formatted 3.5” diskette into your floppy disk drive. 

2. Select File->Make Cam Diskette from the menu at the top of the 

ServoCam® window. 

3. When the operation is complete, remove the diskette from the disk drive. 

If you attempt to make a Cam 

Diskette before saving the 

file, the ServoCam™ 

Designer prompts you to 

save the file to a network or 

local hard drive first. 
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Print the Layout Sheet 
You will probably want to print a layout sheet which will help to set up the 

job. 

1. Select File->Print from the ServoCam® menu.  The following Print 

dialog box will appear: 

 

2. Select the desired printer. 

3. Specify the number of copies. 

4. Check the “Full-page Cam drawing” check box for a full-page printout 

of the cam drawing. 

5. When ready to print, click . 

 

 

Close the File 
After you save the cam and print a layout sheet, you can close the cam file: 

1. Select File->Close from the ServoCam® menu. 

2. Select File->Exit from the ServoCam® menu to exit the ServoCam® 

Designer program. 
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Chapter 4  Running a Part Cycle 
 

 

Overview 
Once you have designed a cam and have put it on a Cam Diskette, you are 

ready to run the cam on the ServoCam® controller. 

This section outlines the procedure for operating the ServoCam® controller. 

Controller Front Panel Lights 
Four colored lights on the controller front panel provide status information: 

GREEN On-cam  

(behaves like a conventional cam) 

BLUE Manual  

(responds to < > keys) 

BLUE flashing Disabled  

(TOOL STOP or EMERGENCY 

STOP is engaged) 

YELLOW Unlocated turret slide  

(use caution near ends of travel 

because it will NOT stop 

automatically) 

YELLOW flashing Camshaft over-speed 

RED Fault (further operation not possible) 

ALL Controller startup and initialization 

 



ServoCam™ User’s Manual 

58 

Operator Alert Light 
An amber alert light is mounted on top of the controller. 

This light comes on whenever the turret-slide force is more than 90% of the 

maximum allowable force. 

Tool Stop Button 
A large, red TOOL STOP button is prominently located on the ServoCam® 

control panel. 

ALWAYS DEPRESS THE TOOL STOP BUTTON BEFORE PLACING 

YOUR HANDS ANYWHERE NEAR THE TURRET SLIDE, TOOL 

TURRET, OR WORKPIECE.  THE SERVOCAM® SYSTEM MAY, AT 

ANY TIME, CAUSE THE TURRET SLIDE TO MOVE 

UNEXPECTEDLY, EVEN IF THE AUTOMATIC SCREW MACHINE 

CAMSHAFTS ARE STOPPED. 

When you are ready to reset the ServoCam® system, simply rotate the 

button clockwise. 

 

WARNING
 

Engaging the TOOL STOP button removes 

power from the ServoCam® actuator(s) and 

stops the screw machine camshafts.  It does 

NOT remove power from the screw machine 

drive motor or accessory motors. 

 

On model SC1000 

controllers, the Tool Stop 

button may be labeled 

“EMERGENCY STOP” 
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Starting the ServoCam® 
Controller 

 

Insert a Cam Diskette 
1. Open the ServoCam® controller by turning the access handle (in front) 

counterclockwise. 

2. Insert your Cam Diskette in the disk drive.  Make sure the diskette label 

is facing up. 

3. Close the controller door.  Turn the handle clockwise to lock it. 

Turn the Controller On 
1. Turn the controller switch On (clockwise).  The On/Off switch is on the 

right side of the controller unit.  The version/copyright screen will 

initially display as follows (this takes about 20 seconds): 

SERVOCAM 

Controller v5.20 

Copyright © 2007 by 

AMT Machine Systems 

2. After the version/copyright screen above, the Main Menu will appear, as 

shown below. 

{Part Cycle Name} 

>Run Part Cycle 

 EDIT Tool AutoAdjs 

 LOAD Part Cycle 

The ServoCam™ controller 

displays up to four text lines. 

A caret (>) beside a menu 

item indicates the item is 

highlighted.  Use the wand 

y arrow keys to scroll 

through all menu items. 

Press e to select the 

highlighted item. 

Press ^ to exit any 

display and return to the 

previous display. 

Use the keys 0 to 9, 

., -, wand y to 

enter tool auto-adjustment 

values.  The BKSP key is 

used to erase errors. 

The z and x keys are 

used to manually “jog” the 

turret slide. 

The AUTO key is used for 

two purposes:  to locate the 

turret slide and to put the 

controller on-cam. 
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Running a Part Cycle 
1. From the Main Menu, use the wand y keys to select RUN Part 

Cycle.  Press e. 

{Part Cycle Name} 

>Run Part Cycle 

 EDIT Tool AutoAdjs 

 LOAD Part Cycle 

2. If requested, locate the turret slide by pressing the AUTO key until the 

yellow light on the controller front panel goes off.  (See the section 

entitled Locate the Turret Slide.) 

3. If requested, locate the camshaft by rotating it until the display changes.  

(See the section entitled Locate the Camshaft.) 

4. The controller briefly displays: 

 

Installing Cam ...   

 

 

5. AutoTripper™-equipped machines only:  Manually set the tool-turret 

station, feeder/chucker, and spindle clutch to the positions shown on the 

ServoCam® controller display.  Set the spindle clutch by tripping it with 

the AutoTripper™ switch. 

6. Put the controller on-cam by pressing the AUTO button until the green 

light illuminates.  (See the section Putting the Controller On-Cam for 

more information.) 

7. 2G models only:  Cock the clutch override mechanism.  (See the section 

Clutch Override for more information.) 

8. The screw machine is now ready for normal operation. 
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Locate the Turret Slide 
1. If the yellow light is on or if the controller shows the following display, 

then the turret slide is un-located. 

LOCATE TURRET SLIDE 

Press AUTO key until 

yellow light out, or 

press ESC to abort 

2. Press and hold the AUTO key until the controller indicates that it has 

located the turret slide.  The yellow light on the front of the controller 

turns off when the controller completes this operation. 

Locate the Camshaft 
1. If the controller shows the following display, then the camshaft is un-

located. 

LOCATE CAMSHAFT 

Rotate it until this 

display changes; or 

press ESC to abort 

2. Jog or handcrank the camshaft until this display changes. 

The ServoCam™ actuator 

position is sensed by an 

incremental optical encoder 

and a home switch.  

Following power-up, the 

controller must “locate” the 

actuator by moving it until it 

triggers the home switch, and 

then moving it again until the 

encoder index pulse is found. 

The ServoCam™ system 

includes a camshaft position 

monitor.  Following power-

up, the controller “locates” 

the camshaft when the 

monitor’s index pulse is 

triggered.  Since the 

ServoCam™ controller 

cannot move the camshaft, 

you must manually rotate it.  

The index pulse is triggered 

when the camshaft passes 

through the 10 hundredths 

position. 
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Display for Running a Part Cycle 
After selecting RUN Part Cycle from the Main Menu, the display indicates 

the part cycle information, based on the camshaft location.  By default, the 

Summary Run Screen is displayed.  There is also a Turret Slide Run Screen. 

Use the w or y keys to cycle through the displays.  Line 1 indicates which screen 

is displayed. 

 

Summary Run Screen 

CS 32.4  

SS=H FD#O T=1        

LOT 10000  200:59:59 

BAR    17    0:21:34 

 

Line 1:  CS 32.4  

where:  

CS 32.4 Camshaft position (hundredths) 
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Line 2:  SS=H FD#O T=1 

where:  

SS=H Spindle speed 

H High 

L Low 

2 Speed 2 

3 Speed 3 

4 Speed 4 

FD#O Bar Feeder 

O Open (Chucker mode) 

C Closed (Chucker mode) 

F Feeding (Feeder mode) 

_ Idle (Feeder mode) 

T=1 Tool turret station 

1 Tool station #1 

and where: = Tripper enabled 

# Tripper disabled 

? Tripper changing state (jog to 

finish) or state unknown (no 

trips defined). 
 

Line 3:  LOT 10000  200:59:59 

See  "Lot Counter" under “Using the Part Counter” for description. 

 

Line 4:  BAR    17    0:21:34 

See  "Bar-End Counter" under “Using the Part Counter” for description. 
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Turret-Slide Run Screen 

Turret Slide 

CS 32.4 SL 0.0957 in 

               F 35% 

3/16 Twist  FDI 14.4 

A description of each line in the display follows: 

 

Line 1: Turret Slide 

 

Line 2:  CS 32.4 SL 0.0957 in 

Line 2 of the display shows the camshaft position in hundredths and the 

distance from the turret to the collet in either inches or millimeters 

where:  

CS 32.4 Camshaft position 

(equals 32.4 hundredths in 

this example) 

SL 0.0957 in Distance of turret from 

collet 

(equals 0.0957 inches in this 

example) 

 

Line 3:  F 35% 

Line 3 of the display shows the percentage of maximum turret force 

where:  

F 35% % of maximum turret force 

(equals 35% in this example) 

 

 

(see next page) 
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Line 4:  3/16 Twist  FDI 14.4 

Line 4 of the display shows the current tool and the description and starting 

hundredth of the current operation 

where:  

3/16 Twist Description of the current tool 

FDI 14.4 Description and starting hdth 

of the current operation  

(equals Feed In starting at 14.4 

hdth in this example) 

and where:  

FCI Feed Change – In 

FCO Feed Change – Out 

FDI Feed In 

C/I Clear/Index 

DWL Dwell 

POS Position 
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Putting the Controller  
On-Cam 

Before running a part cycle, the controller must be on-cam.  When the green 

light is illuminated, the controller is on-cam, and operates in the same 

manner as a conventional cam. 

To put the controller on-cam, press the AUTO button until the green light 

illuminates. 

 

 

Changing Part Cycles 
With ServoCam®, changing part cycles is simple. 

It is not necessary to turn off the controller when changing part cycles. 

1. Insert the new Cam Diskette. 

2. Press ^to view the main menu, if necessary: 

{Part Cycle Name} 

 Run Part Cycle 

 EDIT Tool AutoAdjs 

>LOAD Part Cycle 

3. Use the w or y keys to select LOAD Part Cycle.  Press e. 

4. The display indicates that the cycle is loading. 

5. Now Run the part cycle.  (See the section Running a Part Cycle). 

Note that the turret slide will 

begin to move slowly when 

the AUTO button is pressed, 

so make sure it is free of 

obstruction as it moves into 

place. 



ServoCam™ User’s Manual 
Chapter 4:  Running a Part Cycle 

67 

 

 

 

Using the Tool AutoAdjust Feature 
ServoCam® is equipped with a Tool AutoAdjust feature for making fine tool 

adjustments at the ServoCam® controller.  To use the Tool AutoAdjust 

feature: 

1. From the Main Menu, use the wand y keys to select EDIT Tool 

AutoAdjs.  Then press e.  A display shows the sequence of tools in 

the part cycle. 

 Stn Descrip Adj[in] 

 1   Feed St -0.0186 

 2   Center   0.0032 

>3   3/16 Tw -0.0050 

 4   3/16 Ta  0.0244 

 5   Chamfer -0.0311 

2. Use the wand y keys to select the tool station you want to adjust, 

then press e. 

3. The edit display for that tool appears: 

  Tool AutoAdj [in]  

3   3/16 Twist Drill 

Old AutoAdj  -0.0050 

New AutoAdj>   

4. Enter the adjustment, or press ^ to cancel. 

� To replace the original setting, type in the new value and press 

e. 

� To increase the original setting, press the w key, type in the 

amount to increase, and press e. 

� To decrease the original setting, press the y key, type in the 

amount to decrease, and press e. 

5. Repeat 2 – 4 for each tool that needs adjustment. 

 

(see next page) 

Original Setting 

Enter New  

Setting 

Auto-adjustments made at 

the controller do not change 

the Cam Diskette file.  

Instead, they are stored in 

non-volatile memory in the 

controller. 

Auto-adjustments remain 

valid until: 

√ A different part cycle is 

run, or 

√ The tool table is changed. 

If more than three tools are 

loaded in the part cycle, 

press the y key to view 

the tools that do not appear 

on the display. 

A positive value is like 

tapping the tool longer. 

 

A negative value is like 

tapping the tool shorter. 
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6. Press ^.  The Main Menu appears: 

{Part Cycle Name} 

>Run Part Cycle 

 EDIT Tool AutoAdjs 

 LOAD Part Cycle 

7. Now Run the part cycle.  (See the section Running a Part Cycle). 
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Camshaft Override 
The camshaft override is a device that enables the ServoCam® controller to 

electrically disable the screw machine camshaft. 

This section describes the camshaft override, the conditions which cause it 

to disable the camshaft, and how to return the camshaft to normal operation. 

Theory of Operation 
Like a cam, the ServoCam® actuator is synchronized to the timing of the 

camshaft.  Therefore, if the ServoCam® controller determines that it cannot 

stay synchronized, it needs a way of stopping the camshaft. 

To allow the ServoCam® controller to stop the camshaft, a camshaft 

override device is included in the ServoCam® installation.  The ServoCam® 

controller continuously checks the state of several critical factors (such as 

timing with the camshaft, the Tool Stop button, etc.).  If the ServoCam® 

controller detects a problem, it will issue a command to the camshaft 

override device to disable the camshaft.  Only when the problem has been 

corrected will the controller allow the camshaft to be reactivated. 

The details of how to operate the camshaft override for the different types of 

screw machines are explained next. 

Electrically-Controlled Camshafts 
For screw machines with electrically controlled camshafts (“push-button” 

operation), the ServoCam® camshaft override device is an electrical 

interlock.  No special operator procedures are required to return the camshaft 

to normal operation. 

Mechanically-Controlled Camshafts 
On the Brown and Sharpe 2G, the ServoCam® camshaft override device is a 

spring-loaded, electrically released mechanism that replaces the 90-degree 

bellcrank attached to the backshaft clutch.  To cock the camshaft override 

mechanism, and thus allow the clutch to be engaged, move the clutch lever 

fully to the right (past the detent position). 
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Using the AutoTripper™ System 
The optional AutoTripper™ system replaces the trip dogs for the tool turret, 

the feeder/chucker, the spindle clutch, and the base clutch.  It also controls 

the part deflector on some models.  All trip points are “set” automatically 

when the Cam Diskette is loaded in the controller. 

The initial tool-turret station and feeder/chucker positions are set as usual.  

Their correct positions are always shown on the ServoCam® controller 

display.  The initial spindle-clutch position is set by tripping it with the 

AutoTripper™ switch.  The controller must be off-cam to manually trip the 

spindle clutch.  Base clutch and part deflector control is completely 

automatic. 

Enabling and Disabling AutoTrippers™ 

Bar Feeder AutoTripper™ 
Turning the AutoTripper™ switch OFF disables bar feeding.  Turning it to 

AUTO puts feeding under AutoTripper™ control. 

All AutoTrippers™ 

1. At the Main Menu, use the w or y keys to select DIS/ENABLE 

Trippers.  Press e.  The following will be displayed: 

 

All Trippers 

>    Enable 

     Disable 

2. Use the w or y keys to select either Enable or Disable, then press 

e. 
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Using the Part Counter 
The ServoCam® system is equipped with a part counter feature at the 

ServoCam® controller.  This allows for the tracking of the number of parts 

made with a part cycle. 

The part counter can be set up to count in one of two manners.  The first of 

these is an incremental count of the number of parts made.  The second is a 

decremental count of the number of parts remaining to be made. 

Part-Done Detector 
Before the ServoCam® system can count parts, it must know when to 

consider a part done (or complete).  For this, a part-done detector is used. 

Setting the Part-done Detector 
1. At the Main Menu, select Part Counter Menu and press e. 

2. Select Part-done detector and press e. 

3. Select CyclePhase:  and press e. 

4. Type the cycle phase (in hundredths) where the part should be 

considered done and press e, or press ^ to cancel. 
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Lot Counter 
The ServoCam

®
 system increments the #Parts Done (in Lot) every time a 

part is done – always (AutoTripper™ option not installed), or only if the Bar 

Feeder Switch is set to Auto (AutoTripper™ option installed).   

If the #Parts/Lot (Lot size) is set to UNLIMITED, then the ServoCam
®
 

display counts up the number of parts done (or made), for example:  

LOT  1021 made 

If the #Parts/Lot (Lot size) is set to a value other than UNLIMITED, then 

the ServoCam
®
 display counts down the number of parts and time remaining 

(hh:mm:ss) until the Lot is finished, for example:  

LOT 10000  200:59:59 

When the Lot is finished (#Parts Done equals #Parts/Lot), then the 

ServoCam
®
 system will stop the machine, flash the Operator Alert Light, and 

the display will show "LOT finished".  To stop the Operator Alert Light, 

escape to the Main Menu.  The machine will not run automatically until 

#Parts Done is less than #Parts/Lot or until #Parts/Lot is set to 

UNLIMITED. 

If the AutoTripper™ option is installed, and if the Bar Feeder Switch is 

NOT set to Auto, then the #Parts Done (in Lot) is not incremented, and the 

display will show "NC" on the right-hand side for not counting.  If the 

AutoTripper™ option is not installed, all parts are counted.   

Setting the Lot Counter 
1. To change the #Parts/Lot (lot size): 

2. At the Main Menu, select Part Counter Menu and press e. 

3. Select Lot Counter and press e. 

4. Select #Parts/Lot: and press e. 

5. Type the lot size and press e, or press ^ to cancel. 

6. To change the #Parts Done (number of parts already done in the 

lot): 

7. At the Main Menu, select Part Counter Menu and press e. 

8. Select Lot Counter and press e. 

9. Select #Parts Done: and press e. 

10. Type the number of parts already completed and press e, or 

press ^ to cancel. 
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Bar-End Counter 
This feature is only available with AutoTripper™ option.  The ServoCam

®
 

system increments the #Parts Done (in Bar-end) every time a part is done -- 

if the Bar Feeder Switch is set to Auto and if the bar-end has passed the "bar-

end switch".   

If the #Parts/Bar-end (Bar-end size) is set to UNLIMITED, then the 

ServoCam
®
 display shows: 

BAR unlimited 

If the #Parts/Bar-end (Bar-end size) is set to a value other than 

UNLIMITED, then the ServoCam
®
 display counts down the number of parts 

and time remaining (hh:mm:ss) until the Bar-end is consumed, for example:  

BAR    17    0:21:34 

When the Bar-end is consumed (#Parts Done equals #Parts/Bar-end), then 

the ServoCam
®
 system will stop the machine, flash the Operator Alert Light, 

and the display will show "BAR finished".  To stop the Operator Alert Light, 

escape to the Main Menu.  The Bar-end counter will reset when the 

DRIVESHAFT START button is next pressed. 

If the bar-end has not passed the "bar-end switch", then the bar is long, and 

the ServoCam
®
 display shows, for example: 

BAR long (20+) 

If the Bar Feeder Switch is NOT set to Auto, then the #Parts Done (in Bar-

end) is not incremented, and the display will show "NC" on the right-hand 

side for not counting. 

Note: The term “bar-end” is used here to mean the portion of the bar 

remaining after the bar-end switch activates (enough for multiple parts). 

Setting the Bar-End Counter 
To change the #Parts/Bar-end (bar-end size): 

1. At the Main Menu, select Part Counter Menu and press e. 

2. Select Bar-end Counter and press e. 

3. Select #Parts/Bar-end: and press e. 

4. Type the number of parts per bar-end and press e, or press ^ 

to cancel. 

To change the #Parts Done (number of parts already done out of the bar-

end): 

1. At the Main Menu, select Part Counter Menu and press e. 

2. Select Bar-End Counter and press e. 

3. Select #Parts Done: and press e. 



ServoCam™ User’s Manual 

74 

4. Type the number of parts already done out of the bar end, and press 

e, or press ^ to cancel. 
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Chapter 5 UltraTurn™ Systems 
 

 

Features of the current version 
 

Timeline tick marks 
 There are now tick marks in several of the timeline operations. Below is 

a description of what those marks mean, and what they can be used for. 

 

Operation First tick mark Second tick mark Usage 

Position Time position is 

reached 

(none) The slide is still moving before this point. 

For UltraTurn® Spindle indexing, use this 

to know when it is ok to start the cross tool 

operation. 

Clear Time tools first 

become clear 

Time tools will no 

longer be clear 

The first tick shows the time where the tools 

are first clear of the workpiece. Use this 

time to know when it is ok to either index 

tooling, or index the workpiece. The second 

tick shows the time when the tooling will 

start to re-engage the workpiece, so be sure 

that all indexing is complete before this 

second tick mark. 

 

UltraTurn™ Spindle Indexing 
 Position-mode spindle operations (Position and Traverse) operate only in 3rd  

(4-speed) or Low (2-speed) or Fixed-ratio (1-speed).  A Speed-Change operation 

must be used to switch from velocity mode to position mode, and vice versa. A 

Traverse operation must be used between two position operations. The spindle takes 

some of the initial time of the Position operation to actually get to the requested 

position; allow at least 0.5 second before expecting that the spindle have stopped 

moving, and is at the required position. 

 Example: 

  Turn 

  Speed Change 

  Position 

  Traverse 

  Position 

  Speed Change 

  Turn 

Auto-computation of the spindle operation list is not supported for position mode.  

Auto-computation can be turned on to generate the operation list for the velocity-

mode operations (only), and then turned off to allow manual addition of the position-

mode operations. 
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UltraTurn™ Servoed Turret Indexing 
 For machines equipped with a servoed turret indexer, the indexing direction is 

now dependent upon how many stations the turret has to move. The general rule is 

that the moves are ‘closest direction’, and for moves that are on the exact opposite 

side of the turret, the forward direction is preferred. For example: 

For an 8 hole turret, moving from station 1: 

Destination station Holes moved Direction on indexing 

2 1 Forward 

3 2 Forward 

4 3 Forward 

5 4 Forward 

6 3 Backward 

7 2 Backward 

8 1 Backward 

 

For an 6 hole turret, moving from station 1: 

Destination station Holes moved Direction on indexing 

2 1 Forward 

3 2 Forward 

4 3 Forward 

5 2 Backward 

6 1 Backward 

 

(see next page) 
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UltraTurn™ Control Limits 
The UltraTurn™ software uses predefined limits of motion, velocity and 

acceleration to plan part cycles, and to control the slides and spindle. 

Standard Spindle Speeds 

[zero to full speed time in seconds]:  

Capacity Ratios 1
st
 (High) 2

nd
 3

rd
 (Low) [Fixed] 4

th
 

3/4" 2 5050 [1.360]  2760 [1.360]  

3/4" 4 5018 [1.490] 2757 [0.550] 1417 [1.490] 780 [0.550] 

1 1/4" 2 3500 [1.360]  1912 [1.360]  

1 1/4" 4 3500 [1.560] 1923 [0.520] 988 [1.560] 544 [0.520] 

1 5/8” 1   3000 [0.520]  

1 5/8” 2 3000 [1.850]  1638 [1.840]  

1 5/8” 4 3000 [1.310] 1648 [0.520]   847 [1.310] 466 [0.520] 

2 3/8” 2 2500 [1.220]  1330 [1.220]  

2 3/8” 4 2500 [1.180] 1373 [0.480] 729 [1.180] 400 [0.480] 

 

Reduced Spindle Speeds 

(maximums for 208 Volt systems) [zero to full speed time in seconds]:  

Capacity Ratios 1
st
 (High) 2

nd
 3

rd
 (Low) 4

th
 

3/4" 2 4670 [1.250]  2550 [1.250]  

3/4" 4 4297 [1.270] 2361 [0.470] 1213 [1.270] 668 [0.470] 

1 1/4" 2 3151 [1.230]  1722 [1.220]  

1 1/4" 4 3141 [1.400] 1726 [0.470] 887 [1.400] 488 [0.470] 

1 5/8” 1   2540 [0.440]  

1 5/8” 2 2540 [1.560]  1388 [1.560]  

1 5/8” 4 2549 [1.110] 1400 [0.440] 720 [1.110] 396 [0.440] 

2 3/8” 2 2167 [1.060]  1153 [1.060]  

2 3/8” 4 2263 [1.070] 1243 [0.430] 659 [1.070] 362 [0.430] 

 

Note: For ‘Reduced Speed’, the ‘zero to full speed times’ are shorter since the torque is the same, 

but there is less far to go to get to ‘full speed’. 

 

(see next page)
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Best case Turret indexing times (tip – to – tip) 
(Clear time required with ‘Maximum Tool Auto-Adjust’ set to 0.000):  

 

Turret Indexing times for 8 holes: 

Required Clear time 

(seconds) 

 

Holes Moved 

 

Model 

 

Method 

 

1 

 

2 

 

3 

 

4 

 

5 

 

6 

 

7 

00 Backshaft 120 0.26 0.86 1.47 2.07 2.68 3.28 3.88 

00 Backshaft 240 0.14 0.47 0.80 1.13 1.46 1.79 2.12 

2U Backshaft 120 0.26 0.87 1.47 2.07 2.68 3.28 3.89 

2U Servoed 0.23 0.30 0.36 0.42 0.36 0.30 0.23 

 

NOTE: These times are with the ‘Maximum Tool Auto-Adjust’ set as low as possible.  

 

 

Turret Indexing times for 6 holes: 

Required Clear time 

(seconds) 

 

Holes Moved 

 

Model 

 

Method 

 

1 

 

2 

 

3 

 

4 

 

5 

00 Backshaft 120 0.26 0.86 1.47 2.07 2.68 

00 Backshaft 240 0.14 0.47 0.80 1.13 1.46 

2U Backshaft 120 0.26 0.87 1.47 2.07 2.68 

2U Servoed 0.26 0.34 0.42 0.34 0.26 

 

NOTE: These times are with the ‘Maximum Tool Auto-Adjust’ set as low as possible.  

 

  

(see next page for typical times) 
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Typical case Turret indexing times (tip – to – tip) 
(Clear time required with ‘Maximum Tool Auto-Adjust’ set to 0.100):  

 

Turret Indexing times for 8 holes: 

Required Clear time 

(seconds) 

 

Holes Moved 

 

Model 

 

Method 

 

1 

 

2 

 

3 

 

4 

 

5 

 

6 

 

7 

00 Backshaft 120 0.32 0.92 1.53 2.13 2.73 3.34 3.94 

00 Backshaft 240 0.20 0.53 0.86 1.19 1.51 1.84 2.17 

2U Backshaft 120 0.35 0.95 1.55 2.16 2.76 3.37 3.97 

2U Servoed 0.32 0.38 0.45 0.51 0.45 0.38 0.32 

  

 

Turret Indexing times for 6 holes: 

Required Clear time 

(seconds) 

 

Holes Moved 

 

Model 

 

Method 

 

1 

 

2 

 

3 

 

4 

 

5 

00 Backshaft 120 0.32 0.92 1.53 2.13 2.73 

00 Backshaft 240 0.20 0.53 0.86 1.19 1.51 

2U Backshaft 120 0.35 0.95 1.55 2.16 2.76 

2U Servoed 0.35 0.43 0.51 0.43 0.34 

 

(see next page) 
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Best case UltraTurn™ Spindle indexing times 
 

The best case is to move from a position toward a position of larger angle. The 

spindle index does a ‘one sided approach’, and going backward requires over travel 

in order to achieve the one sided approach. So, the best case is to already be moving 

in the direction of the one sided approach. 

 

Time from clear to clear 

(seconds) 

 

Total Angle moved (degrees) 

 

Model 

 

Spindle 

Size 
Ratios 

 

15 

 

30 

 

60 

 

90 

 

180 

 

270 

 

360 

          

2U 3/4" 1 - - - - - - - 

2U 3/4" 2 0.480 0.400 0.470 0.520 0.630 0.710 0.780 

2U 3/4" 4 0.650 0.550 0.640 0.710 0.860 0.970 1.060 

          

2U 1 1/4" 1 - - - - - - - 

2U 1 1/4" 2 0.570 0.480 0.560 0.620 0.750 0.850 0.930 

2U 1 1/4" 4 0.750 0.640 0.750 0.830 1.000 1.130 1.230 

          

2U 1 5/8" 1 0.300 0.250 0.300 0.330 0.400 0.450 0.490 

2U 1 5/8" 2 0.650 0.550 0.640 0.720 0.870 0.980 1.070 

2U 1 5/8" 4 0.750 0.640 0.740 0.830 1.000 1.130 1.230 

          

3U 2 3/8" 1 - - - - - - - 

3U 2 3/8" 2 0.570 0.480 0.570 0.630 0.760 0.860 0.940 

3U 2 3/8" 4 0.790 0.670 0.780 0.870 1.050 1.190 1.300 

 

 

 

 

(see next page)
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The following slide coordinates are listed as Turret Slide (TS), Front Cross (FC), Rear Cross (RC), Front Vertical 

(FV), and Rear Vertical (RV). You can get to the full range, but you have to leave space for the 'getting up to speed' 

when starting a feed near the fully retracted position. 

#2 Regular Slides 
Vertical slides are interfering at the fully in position (FV 4.59 or less, RV 4.3 or less). 

 

TS 9.9762 to 3.0984 

FC 5.1900 to 3.4400 (slide adj set to 0.0000) 

RC 5.1900 to 3.4400 (slide adj set to 0.0000) 

FV 7.1000 to 4.1000 

RV 7.1000 to 4.1000 

 

FC 5.6900 to 3.9400 (slide adj set to 0.5000) 

RC 5.6900 to 3.9400 (slide adj set to 0.5000)  

#3 Regular Slides 
Vertical slides are interfering at the fully in position (FV 4.59 or less, RV 4.3 or less). 

 
TS 9.9762 to 3.0984 

FC 5.1900 to 3.4400 (slide adj set to 0.0000) 

RC 5.1900 to 3.4400 (slide adj set to 0.0000) 

FV 7.7000 to 4.7000 

RV 7.7000 to 4.7000 

 

FC 5.6900 to 3.9400 (slide adj set to 0.5000) 

RC 5.6900 to 3.9400 (slide adj set to 0.5000)  

 

(see next page) 
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#2 Ram Slides 
Vertical slides are interfering at the fully in position  (FV 3.5 or less, RV 3.5 or less) 

 

TS 9.9762 to 3.0984 

FC 5.1900 to 3.4400 (slide adj set to 0.0000) 

RC 5.1900 to 3.4400 (slide adj set to 0.0000) 

FV 6.1100 to 3.1100 

RV 6.0900 to 3.0900 

 

FC 5.6900 to 3.9400 (slide adj set to 0.5000) 

RC 5.6900 to 3.9400 (slide adj set to 0.5000)  

 

#3 Ram Slides 
Vertical slides are interfering at the fully in position (FV 3.5 or less, RV 3.5 or less) 

 

TS 9.9762 to 3.0984 

FC 5.1900 to 3.4400 (slide adj set to 0.0000) 

RC 5.1900 to 3.4400 (slide adj set to 0.0000) 

FV 6.1100 to 3.1100 

RV 6.0900 to 3.0900 

 

FC 5.6900 to 3.9400 (slide adj set to 0.5000) 

RC 5.6900 to 3.9400 (slide adj set to 0.5000)  
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Chapter 6 Reference 
 

 

Opening the 
ServoCam® Designer Application 

Windows 95 and higher 

1. Click the  Button.  Select Programs from the Start menu. 

  

2. Select the ServoCam® folder.  The ServoCam® program icon appears. 

3. Click the ServoCam® program icon. 

 

 

Windows™ Menu &  
Dialog Box Conventions 

This section provides an overview of Windows dialog box and menu 

conventions. If you are unfamiliar with Windows, the information in this 

section will help you navigate more easily in ServoCam® Designer. 

Choosing Commands from Menus 
The ServoCam® Designer menu bar is located just below the application 

title bar: 

 

You can access ServoCam® Designer menu options with the mouse or the 

keyboard. 

With the Mouse 
1. Click the desired menu title to display menu options: 
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2. Click the desired option to execute the command. 

With the Keyboard 

1. Press and hold the a key to activate the menu bar. 

2. Press the underlined letter of the desired menu title to display menu 

options. 

OR 

Use the right and left arrow keys to select the desired menu title and 

press e to display menu options. 

3. Press the underlined letter of the desired option to execute the command. 

OR 

Use the up and down arrow keys (wand y) to select the desired 

command and press e to execute. 

To cancel a menu display 

without executing a 

command, click on another 

part of the screen or press 

^. 
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Working with Dialog Boxes 
Essentially, dialog boxes are windows containing a variety of commands—

typically, adjustments to application settings.  Each of the five command 

buttons on the ServoCam® Designer window leads to a dialog box: 

Navigating in Dialog Boxes 

When using a mouse with a 

dialog box, simply click the option you wish to adjust. When using the 

keyboard, press the Tab v key to move from option to option or press 

a and the underlined letter in the option to move there directly.  
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Dialog Box Controls 
The following table provides an overview of typical dialog box controls and 

how to use them with the mouse and the keyboard. 

Control Mouse Keyboard 

OK button 

 

Click to execute dialog 

box commands. 
Press eto execute 

dialog box commands. 

Cancel button 

 

Click to close the 

dialog box without 

executing a command. 

Press ^to close 

the dialog box without 

executing a command. 

Checkbox 

 
Click to turn on/off 

option. 
Press k to turn 

on/off option. 

Radio buttons 

 

Click on desired radio 

button to choose option 

(in a group of radio 

buttons, only one can 

be selected).  

Use arrow keys to 

choose an option (in a 

group of radio buttons, 

only one can be 

selected). 

List box 

 

Click on the desired 

item. 
Use arrow keys to 

select the desired item. 

Drop-down list box 

 

Click arrow next to the 

box to display list; click 

desired item to select it. 

Use the arrow keys to 

select desired item. 

Text box 

 

Click in the box or drag 

the mouse pointer 

across existing text; 

type your own text. 

Type your own text. 
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ServoCam® 
Designer Menus 

The ServoCam® Designer software provides you with several menu options 

for use while designing a cam.  The following instruction convention is used 

throughout this manual:  Menu title->Command. 

For example, when you see an instruction to click 

File->Print 

File indicates the menu title, and Print indicates the command. 

 

Saving Files 
We recommend that you save your data at regular intervals while designing 

or editing a cam. 

To save a file while you are working on a design, select 

File->Save 

from the ServoCam® menu. 
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Using the Info 
Button 

The majority of the ServoCam® screens are equipped with an Info button.  

In its normal state, the button is gray.   

Whenever data associated with a particular window is Invalid or Out of 

Range, the Info button is red.  Also, the Info button will turn yellow 

whenever data associated with a particular window is Valid but there is a 

warning.   

When the Info button is red or yellow, click it.  A window similar to the 

following appears: 

Make a note of which parameters may be causing the problem, then click 

 to close the window. 

Return to the screens associated with the listed parameters, and adjust as 

necessary. 
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Chapter 7 System Requirements 
 

 

Requirements for  
ServoCam® Designer  
Application 

 

• Windows 95, 98, 2000, NT, or XP 

• Pentium-class processor or equivalent 

• 8 MB of RAM (More is always better) 

• 10 MB of free hard disk space  

(15 MB more is required if Adobe Acrobat™ is not already installed on 

your PC.) (Again, more is always better) 

• 800x600 pixel VGA video or higher 

• 3.5-inch floppy drive (Not required if using DNC to transfer files) 

• CD-ROM drive (Only used if installing software from a CD) 
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Chapter 8 Troubleshooting 
 

 

Introduction 
The ServoCam® system provides several types of information for 

troubleshooting:  datalogs, diagnostic messages, and diagnostic software. 

Each of these is described in the following sections. 

 

 

Datalogs 
The ServoCam® controller continuously stores operating data in memory, 

which can be useful for troubleshooting.  To view this data, it has to be 

copied from memory to a floppy disk. 

This procedure is called archiving datalogs and is described below. 

Archiving Datalogs 
1. The data must be captured before it can be archived.   

• If the ServoCam® controller has a Fault, the data is captured 

automatically and you can skip to step 2. 

• Otherwise, the data is captured the instant the TOOL STOP button 

on the ServoCam® controller is pressed.  Leave the TOOL STOP 

button depressed throughout the rest of this procedure. 

2. If the Main Menu is not showing on the controller display, press the 

[ESC] key.  The Main Menu appears: 

<Part Cycle Name> 

>Run Part Cycle 

 EDIT Tool AutoAdjs 

 LOAD Part Cycle 

 Advanced Menu 

3. Use the [ ↑ ]and [ ↓ ] keys to select Advanced Menu.  Then press the 

[ENTER] key. 

4. Use the [ ↑ ]and [ ↓ ] keys to select Archive Datalog.  Then press the 

[ENTER] key. 

5. The display indicates that data is being archived.  When complete, the 

Advanced Menu appears. 

6. Press the [ESC] key and the Main Menu appears. 

If the ServoCam™ controller 

has a Fault, you should 

immediately archive datalogs. 
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The datalogs are now on the floppy diskette.  If your ServoCam® controller 

has a Fault, complete the remaining steps before removing the floppy 

diskette. 

7. Press the [ESC] key and select YES to shutdown the ServoCam® 

controller. 

8. A warning message appears.  Press the [ESC] key to log the warning and 

continue to shutdown the ServoCam® controller. 

9. Switch off the controller and remove the floppy diskette. 

Once archived, the entire contents of the diskette should be emailed to 

ServoCam® technical support 

 servocam@mail.com 

if assistance from AMT Machine Systems is required. 
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Diagnostic Messages 
In case of a problem, the ServoCam® controller will generally display a 

useful diagnostic message.  The following list describes the ServoCam® 

messages that result from easily correctable problems.   

If the suggested solutions do not eliminate the problem, or if you see a 

diagnostic message that is not included in this list, please contact 

ServoCam® technical support. 

List of Diagnostic Messages 

Warning: Cannot read old file format, load aborted (0) 

Possible Cause The Cam Diskette being read was 

generated by an old version of the 

ServoCam® Designer and cannot 

by read by the controller. 

Solution Open the part cycle in a newer 

version of the ServoCam® 

Designer and create a new Cam 

Diskette. 

Warning: Diskette or file problem, data not archived (0) 

Possible Cause Missing diskette. 

Solution Try again with a diskette in place. 

Possible Cause Faulty diskette, write-protected 

diskette or diskette full. 

Solution Try again with a new, formatted, 

non-write-protected, empty 

diskette. 

Warning: FailMon: FAILED (DECL: Air pressure fault (0)) (0) 

Possible Cause Inadequate air supply to 

AutoTripper™ system 

Solution Verify air supply to 

AutoTripper™ system meets 

specifications. 

Some diagnostic messages 

may not show up until the 

ServoCam™ controller is 

shut down.  It is 

recommended to shut down 

the controller in the following 

manner after a fault (red 

light):   

√ From Advanced Menu, 

select Archive Datalog. 

√ When complete, press 

ESC key as many times 

as necessary to get to the 

Shutdown Menu,  

√ Select “Yes” for shutdown. 
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Warning: FailMon: FAILED (DECL: Excess servo pos error 
(MotorPosError)) (0) 

Possible Cause Collision at the ends of turret-slide 

travel during manual movement. 

Solution If the turret slide was not yet 

located, this is normal; restart and 

stay away from ends of travel until 

the turret slide is located.  If the 

turret slide was located, please call 

technical support. 

Possible Cause Collision with workpiece, cross 

slides or some part of the screw 

machine. 

Solution Avoid the collision, usually by 

adjusting the timing of some 

operations. 

Warning: FailMon: FAILED (DECL: Front-shaft encoder consistency 
error (Diff)) (0) 

Possible Cause Front-shaft (camshaft) encoder is 

not counting correctly; the count is 

not consistent. 

Solution Check the camshaft encoder 

mounting and cable connections. 

Warning: FailMon: FAILED (DECL: Motor encoder consistency error 
(Diff)) (0) 

Possible Cause Motor encoder is not counting 

correctly; the count is not 

consistent. 

Solution Check the cables and connections 

to the ServoCam® actuator. 

Warning: FailMon: FAILED (DECL: Motor fault NOT signaled (0)) (0) 

Possible Cause Malfunctioning servo amplifier or 

related component problem. 

Solution Contact ServoCam® technical 

support. 
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Warning: FailMon: FAILED (DECL: Motor fault signaled (0)) (0) 

Possible Cause Malfunctioning servo amplifier or 

related component problem. 

Solution Contact ServoCam® technical 

support. 

Warning: FailMon: FAILED (DECL: Motor temperature too high (0)) (0) 

Possible Cause The motor is operating at high 

forces during most of the part 

cycle. 

Solution Add some delays to the part cycle 

to allow the motor to cool, or slow 

down the cutting operations to 

reduce the force required. 

Warning: FailMon: FAILED (DECL: Tripper fault (ErrorCode)) (0) 

Possible Cause Tripper hardware is not 

functioning properly. 

Solution In the screw machine electrical 

cabinet, verify that the cable from 

the ServoCam® controller is 

connected to the AutoTripper™ 

control module. 

Warning: Macro read problem (no mem or bad data), load aborted 
(MacroIndex) 

Possible Cause Corrupt part-cycle file. 

Solution Make sure that the file is a valid 

part cycle that can be read by the 

ServoCam® Designer. 

Possible Cause Any file read problem, including a 

machine type/cam type that the 

controller does not recognize. 

Solution Make sure that the part cycle was 

designed for the machine type/cam 

type being used. 
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Warning: Macro read problem (unknown), load aborted (MacroIndex) 

Possible Cause Corrupt part-cycle file. 

Solution Make sure that the file is a valid 

part cycle that can be read by the 

ServoCam® Designer. 

Warning: No diskette in A: drive, part cycle not loaded (0) 

Warning: No diskette in B: drive, part cycle not loaded (0) 

Possible Cause Missing diskette. 

Solution Try again with a Cam Diskette in 

place. 

Possible Cause Faulty diskette. 

Solution Try again with a new diskette. 

Warning: NVMem corrupt, cannot init tool info (ToolNumber) 

Warning: NVMem corrupt, cannot store tool info (ToolNumber) 

Possible Cause Non-volatile memory has been 

corrupted, by large static 

discharge or some other cause. 

Solution Clear the memory with the Main 

Menu command [Advanced Menu 

| Clear state memory].  (Any tool 

auto-adjust values will be lost.) 

Warning: Old program cannot read new file format, load aborted (0) 

Possible Cause The Cam Diskette being read was 

generated by a newer version of 

the ServoCam® Designer and 

cannot by read by the controller. 

Solution Update the controller to a newer 

version of software 

(recommended), or use an older 

version of the ServoCam® 

Designer to create the Cam 

Diskette. 
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Warning: Reqd <CapabName> capability not avail, load aborted 
(CapabNumber) 

Possible Cause The part cycle was designed for a 

controller with different 

capabilities. 

Solution Make sure that the part cycle was 

designed for the machine type/cam 

type being used.  Frequently, the 

part cycle will only require slight 

additional design changes to allow 

it to run on a different machine. 

Warning: Unable to open file '<filename>', part cycle not loaded (0) 

Possible Cause Cam Diskette does not contain the 

required file (SERVOCAM.SCM). 

Solution Use the option [File | Make Cam 

Diskette] in the ServoCam® 

Designer to put the file on the 

diskette. 

Possible Cause Faulty diskette. 

Solution Try again with a new diskette. 
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Diagnostic Software 
A ServoCam® Diagnostic Diskette is included with each system.  This 

diskette contains software that is particularly useful for troubleshooting 

problems with sensors and the controller display and keypad. 

The ServoCam® Diagnostic software is described below: 

Using the ServoCam® Diagnostic 
Software 

1. Insert the ServoCam® Diagnostic Diskette into the controller floppy 

drive. 

2. Turn the controller switch ON.  The following screen will initially 

display as follows (this takes about 20 seconds): 

 

 

      Getting 

ServoCam .CFG files 

3. After the initial screen above, the SERVOCAM DIAGNOSTIC screen 

will appear, as shown below: 

SERVOCAM DIAGNOSTIC 

HM: _  KL: _  CL: D 

FS: _ ^ 0000  FL:2.0 

TS: _ ^ 0000000 b___ 

4. Press 5 on the keypad to test the controller lights (four on front panel 

and beacon on top). 

5. Press 8 on keypad to change the clutch override state between enabled 

and disabled. 
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Description of Diagnostic Software 
Display 

A description of each line in the diagnostic software display follows: 

 

Line 1:  SERVOCAM DIAGNOSTIC 

Line 1 of the display is the title showing that the ServoCam Diagnostic 

Software is being run. 

 

Line 2:  HM: _  KL: _  CL: D 

Line 2 of the display shows the current state of the actuator home switch, the 

TOOL STOP button (kill switch), and the clutch override 

where:  

HM: Actuator home switch 

X in home position 

_ NOT in home position 

KL: TOOL STOP button 

X pressed 

_ NOT pressed 

CL: Clutch override 

D Disabled backshaft 

E Enabled backshaft 

 

Line 3:  FS: _ ^ 0000  FL:2.0 

Line 3 of the display shows the current state of the camshaft encoder 

where:  

FS: Camshaft encoder 

(which is broken into the 

following three regions) 

_ Camshaft index pulse 

X On index pulse 

_ NOT on index pulse 

^ Direction to closest index pulse 

^ increase encoder counts 

v decrease encoder counts 

? not seen index pulse yet 

0000 Camshaft encoder count 

(wraps at 4000 for 2G; otherwise 

wraps at 4096) 

The green light on the 

controller front panel also 

illuminates when the 

camshaft index pulse is On. 



ServoCam™ User’s Manual 

100 

and the size of the controller flash disk 

where:  

FL: Controller flash disk (in Mb) 

(equals 2.0 Mb in the example) 

 

Line 4:  TS: _ ^ 0000000 b___ 

Line 4 of the display shows the current state of the motor encoder of the 

actuator 

where:  

TS: Motor encoder 

(which is broken into the 

following three regions) 

_ Motor index pulse 

X On index pulse 

_ NOT on index pulse 

^ Direction to closest index pulse 

^ increase encoder counts 

v decrease encoder counts 

? not seen index pulse yet 

0000000 Motor encoder count 

(does not wrap) 

and a four-character area for feedback from the controller keypad 

where:  

b Recently pressed key 

0-9 Digit key 

. Period key 

- Minus key 

S ESC key 

b BKSP key 

E Enter key 

^ Up-arrow key 

v Down-arrow key 

___ Directional keys 

X__ Left-arrow key 

_X_ AUTO key 

__X Right-arrow key 

 

 

The blue  light on the 

controller front panel also 

illuminates when the motor 

index pulse is On. 


